]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/testsuite/Makefile.am
Fixes to who-test: accept any ident, escape some '*' flags.
[ngircd-alex.git] / src / testsuite / Makefile.am
index c5eccc3c5760edebb836b5ba331898558ca9c74d..bc8df8442deb534d61a6f4f25ad3c21397249904 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.4 2002/09/20 14:46:55 alex Exp $
+# $Id: Makefile.am,v 1.18 2008/02/17 13:26:42 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -17,36 +17,60 @@ AUTOMAKE_OPTIONS = ../portab/ansi2knr
 INCLUDES = -I$(srcdir)/../portab
 
 EXTRA_DIST = \
-       getpid.sh \
+       README functions.inc getpid.sh \
        start-server.sh stop-server.sh tests.sh stress-server.sh \
-       connect-test.e channel-test.e mode-test.e \
-       stress-A.e stress-B.e check-idle.e \
+       test-loop.sh wait-tests.sh \
+       channel-test.e connect-test.e check-idle.e misc-test.e mode-test.e \
+       opless-channel-test.e \
+       who-test.e stress-A.e stress-B.e \
        ngircd-test.conf
 
+all:
+
 clean-local:
-       rm -rf logs tests *-test ngircd-test.log ngircd-test.motd ngircd-TEST procs.tmp 
+       rm -rf logs tests *-test ngircd-test.log ngircd-test.motd \
+        T-ngircd procs.tmp 
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
-check_SCRIPTS = ngircd-TEST tests.sh
+check_SCRIPTS = ngircd-TEST-Binary tests.sh
 
-ngircd-TEST:
-       ln -s ../ngircd/ngircd ngircd-TEST
+ngircd-TEST-Binary:
+       cp ../ngircd/ngircd T-ngircd
+       [ -f getpid.sh ] || ln -s $(srcdir)/getpid.sh .
 
 connect-test: tests.sh
+       rm -f connect-test
        ln -s $(srcdir)/tests.sh connect-test
 
 channel-test: tests.sh
+       rm -f channel-test
        ln -s $(srcdir)/tests.sh channel-test
 
+opless-channel-test: tests.sh
+       rm -f opless-channel-test
+       ln -s $(srcdir)/tests.sh opless-channel-test
+
+who-test: tests.sh
+       rm -f who-test
+       ln -s $(srcdir)/tests.sh who-test
+
+misc-test: tests.sh
+       rm -f misc-test
+       ln -s $(srcdir)/tests.sh misc-test
+
 mode-test: tests.sh
+       rm -f mode-test
        ln -s $(srcdir)/tests.sh mode-test
 
 TESTS = start-server.sh \
        connect-test \
        channel-test \
+       misc-test \
        mode-test \
+       who-test \
+       opless-channel-test \
        stress-server.sh \
        stop-server.sh