Update autogen.sh & INSTALL for pkg-config requirements