]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/testsuite/Makefile.am
Implement RFC 2812 handling of "0" argument to JOIN
[ngircd-alex.git] / src / testsuite / Makefile.am
index 4ee7e448f229abdd9b842bf5deaeacb8d035e9be..d02e4e1954a57fc245f9097544c0b3752c6c8337 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.10 2004/09/04 13:58:31 alex Exp $
+# $Id: Makefile.am,v 1.15 2007/11/18 15:07:16 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -17,13 +17,14 @@ AUTOMAKE_OPTIONS = ../portab/ansi2knr
 INCLUDES = -I$(srcdir)/../portab
 
 EXTRA_DIST = \
-       getpid.sh \
+       README functions.inc getpid.sh \
        start-server.sh stop-server.sh tests.sh stress-server.sh \
+       test-loop.sh wait-tests.sh \
        connect-test.e channel-test.e mode-test.e \
        stress-A.e stress-B.e check-idle.e \
        ngircd-test.conf
 
-all: ngircd-TEST-Binary
+all:
 
 clean-local:
        rm -rf logs tests *-test ngircd-test.log ngircd-test.motd \
@@ -39,12 +40,15 @@ ngircd-TEST-Binary:
        [ -f getpid.sh ] || ln -s $(srcdir)/getpid.sh .
 
 connect-test: tests.sh
+       rm -f connect-test
        ln -s $(srcdir)/tests.sh connect-test
 
 channel-test: tests.sh
+       rm -f channel-test
        ln -s $(srcdir)/tests.sh channel-test
 
 mode-test: tests.sh
+       rm -f mode-test
        ln -s $(srcdir)/tests.sh mode-test
 
 TESTS = start-server.sh \