]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/testsuite/Makefile.am
Added support for Solaris 11.
[ngircd-alex.git] / src / testsuite / Makefile.am
index 831d25832eb3cf0053bbd8570b7ca8d715574315..77138785ba26507a00443ae92d0b376c28e85ef2 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.7 2002/09/20 15:12:42 alex Exp $
+# $Id: Makefile.am,v 1.14 2004/09/08 09:40:51 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -17,15 +17,18 @@ AUTOMAKE_OPTIONS = ../portab/ansi2knr
 INCLUDES = -I$(srcdir)/../portab
 
 EXTRA_DIST = \
-       getpid.sh \
+       README functions.inc getpid.sh \
        start-server.sh stop-server.sh tests.sh stress-server.sh \
+       test-loop.sh wait-tests.sh \
        connect-test.e channel-test.e mode-test.e \
        stress-A.e stress-B.e check-idle.e \
        ngircd-test.conf
 
+all:
+
 clean-local:
        rm -rf logs tests *-test ngircd-test.log ngircd-test.motd \
-        ngircd-TEST* procs.tmp 
+        T-ngircd procs.tmp 
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
@@ -33,7 +36,8 @@ maintainer-clean-local:
 check_SCRIPTS = ngircd-TEST-Binary tests.sh
 
 ngircd-TEST-Binary:
-       cp ../ngircd/ngircd ngircd-TEST
+       cp ../ngircd/ngircd T-ngircd
+       [ -f getpid.sh ] || ln -s $(srcdir)/getpid.sh .
 
 connect-test: tests.sh
        ln -s $(srcdir)/tests.sh connect-test