]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/testsuite/Makefile.am
Make IRC_WHO also search username/servername/hostname.
[ngircd-alex.git] / src / testsuite / Makefile.am
index a0be2818b1433b3e8ed0a3c54bafd61da14125d3..58a617ee61b858705b4cf2bea7b6413639b8cf89 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.5 2002/09/20 15:08:12 alex Exp $
+# $Id: Makefile.am,v 1.16 2008/02/11 11:06:32 fw Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -17,35 +17,49 @@ AUTOMAKE_OPTIONS = ../portab/ansi2knr
 INCLUDES = -I$(srcdir)/../portab
 
 EXTRA_DIST = \
-       getpid.sh \
+       README functions.inc getpid.sh \
        start-server.sh stop-server.sh tests.sh stress-server.sh \
+       test-loop.sh wait-tests.sh \
        connect-test.e channel-test.e mode-test.e \
+       who-away-test.e
        stress-A.e stress-B.e check-idle.e \
        ngircd-test.conf
 
+all:
+
 clean-local:
-       rm -rf logs tests *-test ngircd-test.log ngircd-test.motd ngircd-TEST procs.tmp 
+       rm -rf logs tests *-test ngircd-test.log ngircd-test.motd \
+        T-ngircd procs.tmp 
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
-check_SCRIPTS = ngircd-TEST tests.sh
+check_SCRIPTS = ngircd-TEST-Binary tests.sh
 
-ngircd-TEST:
-       cp ../ngircd/ngircd ngircd-TEST
+ngircd-TEST-Binary:
+       cp ../ngircd/ngircd T-ngircd
+       [ -f getpid.sh ] || ln -s $(srcdir)/getpid.sh .
 
 connect-test: tests.sh
+       rm -f connect-test
        ln -s $(srcdir)/tests.sh connect-test
 
 channel-test: tests.sh
+       rm -f channel-test
        ln -s $(srcdir)/tests.sh channel-test
 
+who-away-test: tests.sh
+       rm -f who-away-test
+       ln -s $(srcdir)/tests.sh who-away-test
+
 mode-test: tests.sh
+       rm -f mode-test
        ln -s $(srcdir)/tests.sh mode-test
 
 TESTS = start-server.sh \
        connect-test \
        channel-test \
+       who-away-test \
        mode-test \
        stress-server.sh \
        stop-server.sh