]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/testsuite/Makefile.am
Make IRC_WHO also search username/servername/hostname.
[ngircd-alex.git] / src / testsuite / Makefile.am
index 81d6c11a5af2f81ab7cb3f530b45b564c4d0e45b..58a617ee61b858705b4cf2bea7b6413639b8cf89 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.13 2004/09/06 20:35:28 alex Exp $
+# $Id: Makefile.am,v 1.16 2008/02/11 11:06:32 fw Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -17,10 +17,11 @@ AUTOMAKE_OPTIONS = ../portab/ansi2knr
 INCLUDES = -I$(srcdir)/../portab
 
 EXTRA_DIST = \
-       README getpid.sh \
+       README functions.inc getpid.sh \
        start-server.sh stop-server.sh tests.sh stress-server.sh \
        test-loop.sh wait-tests.sh \
        connect-test.e channel-test.e mode-test.e \
+       who-away-test.e
        stress-A.e stress-B.e check-idle.e \
        ngircd-test.conf
 
@@ -40,17 +41,25 @@ ngircd-TEST-Binary:
        [ -f getpid.sh ] || ln -s $(srcdir)/getpid.sh .
 
 connect-test: tests.sh
+       rm -f connect-test
        ln -s $(srcdir)/tests.sh connect-test
 
 channel-test: tests.sh
+       rm -f channel-test
        ln -s $(srcdir)/tests.sh channel-test
 
+who-away-test: tests.sh
+       rm -f who-away-test
+       ln -s $(srcdir)/tests.sh who-away-test
+
 mode-test: tests.sh
+       rm -f mode-test
        ln -s $(srcdir)/tests.sh mode-test
 
 TESTS = start-server.sh \
        connect-test \
        channel-test \
+       who-away-test \
        mode-test \
        stress-server.sh \
        stop-server.sh