]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/testsuite/Makefile.am
Added support for looping and other enhancements.
[ngircd-alex.git] / src / testsuite / Makefile.am
index 831d25832eb3cf0053bbd8570b7ca8d715574315..4ee7e448f229abdd9b842bf5deaeacb8d035e9be 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.7 2002/09/20 15:12:42 alex Exp $
+# $Id: Makefile.am,v 1.10 2004/09/04 13:58:31 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -23,9 +23,11 @@ EXTRA_DIST = \
        stress-A.e stress-B.e check-idle.e \
        ngircd-test.conf
 
+all: ngircd-TEST-Binary
+
 clean-local:
        rm -rf logs tests *-test ngircd-test.log ngircd-test.motd \
-        ngircd-TEST* procs.tmp 
+        T-ngircd procs.tmp 
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
@@ -33,7 +35,8 @@ maintainer-clean-local:
 check_SCRIPTS = ngircd-TEST-Binary tests.sh
 
 ngircd-TEST-Binary:
-       cp ../ngircd/ngircd ngircd-TEST
+       cp ../ngircd/ngircd T-ngircd
+       [ -f getpid.sh ] || ln -s $(srcdir)/getpid.sh .
 
 connect-test: tests.sh
        ln -s $(srcdir)/tests.sh connect-test