]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/testsuite/Makefile.am
Fixed spelling mistake :-)
[ngircd-alex.git] / src / testsuite / Makefile.am
index 85c855464f88b36ebe3129f11d455ba393a8e424..31048ca2dcc61ee7b082ac51e793005afdbb1ad6 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.2 2002/09/09 22:56:07 alex Exp $
+# $Id: Makefile.am,v 1.9 2002/11/10 14:28:06 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -17,27 +17,33 @@ AUTOMAKE_OPTIONS = ../portab/ansi2knr
 INCLUDES = -I$(srcdir)/../portab
 
 EXTRA_DIST = \
+       getpid.sh \
        start-server.sh stop-server.sh tests.sh stress-server.sh \
        connect-test.e channel-test.e mode-test.e \
-       stress-A.e stress-B.e check-idle.e
+       stress-A.e stress-B.e check-idle.e \
        ngircd-test.conf
 
 clean-local:
-       rm -rf logs tests *-test ngircd-test.log ngircd-test.motd
+       rm -rf logs tests *-test ngircd-test.log ngircd-test.motd \
+        T-ngircd procs.tmp 
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
-check_SCRIPTS = tests.sh
+check_SCRIPTS = ngircd-TEST-Binary tests.sh
+
+ngircd-TEST-Binary:
+       cp ../ngircd/ngircd T-ngircd
+       [ -f getpid.sh ] || ln -s $(srcdir)/getpid.sh .
 
 connect-test: tests.sh
-       ln -s tests.sh connect-test
+       ln -s $(srcdir)/tests.sh connect-test
 
 channel-test: tests.sh
-       ln -s tests.sh channel-test
+       ln -s $(srcdir)/tests.sh channel-test
 
 mode-test: tests.sh
-       ln -s tests.sh mode-test
+       ln -s $(srcdir)/tests.sh mode-test
 
 TESTS = start-server.sh \
        connect-test \