]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/portab/Makefile.am
Test for gai_strerror()
[ngircd-alex.git] / src / portab / Makefile.am
index a6e8889245903c2f2cda42526c901030dea606b5..a57ea4959803aa160013f5f9c56020d8f0eab8a8 100644 (file)
@@ -9,14 +9,22 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.2 2002/03/15 15:41:55 alex Exp $
-#
+
+AUTOMAKE_OPTIONS = ansi2knr
+
+noinst_LIBRARIES = libngportab.a
+
+libngportab_a_SOURCES = strdup.c strlcpy.c strtok_r.c vsnprintf.c waitpid.c
 
 check_PROGRAMS = portabtest
 
 portabtest_SOURCES = portabtest.c
 
-noinst_HEADERS = imp.h exp.h portab.h
+portabtest_LDFLAGS = -L.
+
+portabtest_LDADD = -lngportab
+
+noinst_HEADERS = imp.h exp.h portab.h splint.h
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in