]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/portab/Makefile.am
- Link portabtest agains "true" library.
[ngircd-alex.git] / src / portab / Makefile.am
index 7c8d15fec931fbd3008fe74ec3edde772e1bb3b1..7020462d15083e44d99d2e2005787fdc8ff6bd35 100644 (file)
@@ -9,13 +9,23 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.1 2002/03/12 14:36:44 alex Exp $
+# $Id: Makefile.am,v 1.7 2003/01/03 22:04:14 alex Exp $
 #
 
-noinst_PROGRAMS = portabtest
+AUTOMAKE_OPTIONS = ansi2knr
+
+noinst_LIBRARIES = libngportab.a
+
+libngportab_a_SOURCES = strlcpy.c vsnprintf.c
+
+check_PROGRAMS = portabtest
 
 portabtest_SOURCES = portabtest.c
 
+portabtest_LDFLAGS = -L.
+
+portabtest_LDADD = -lngportab
+
 noinst_HEADERS = imp.h exp.h portab.h
 
 maintainer-clean-local: