]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- neue Konfigurationsoption "OperCanUseMode" (Sektion "Global"):
[ngircd-alex.git] / src / ngircd / Makefile.am
index a2d7365a177fac20810a140888888ef78e040e01..d3c4c80ba884deb36f4b75146ce13e769a2aa0e4 100644 (file)
@@ -9,12 +9,12 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.23 2002/05/27 11:25:17 alex Exp $
+# $Id: Makefile.am,v 1.26 2002/07/22 13:23:28 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
 
-AM_CFLAGS = -I$(srcdir)/../portab
+INCLUDES = -I$(srcdir)/../portab
 
 LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
 
@@ -22,7 +22,7 @@ sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
        irc-channel.c irc-login.c irc-mode.c irc-op.c irc-oper.c irc-server.c \
-       irc-write.c lists.c log.c parse.c resolve.c tool.c
+       irc-write.c lists.c log.c match.c parse.c resolve.c tool.c
 
 ngircd_LDFLAGS = -L../portab
 
@@ -30,7 +30,7 @@ ngircd_LDADD = -lngportab
 
 noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
        irc-channel.h irc-login.h irc-mode.h irc-op.h irc-oper.h irc-server.h \
-       irc-write.h lists.h log.h parse.h resolve.h tool.h \
+       irc-write.h lists.h log.h match.h parse.h resolve.h tool.h \
        messages.h defines.h
 
 clean-local:
@@ -53,7 +53,7 @@ lint:
        rm -f lint.out
        for f in *.c; do \
         echo "checking $$f ..."; \
-        splint $$f $(LINTARGS) -I./.. $(AM_CFLAGS) > lint.out 2>&1; \
+        splint $$f $(LINTARGS) -I./.. -I./../portab $(AM_CFLAGS) > lint.out 2>&1; \
         grep "no warnings" lint.out > /dev/null 2>&1; \
         if [ $$? -ne 0 ]; then \
          echo; cat lint.out; echo; \