]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- "check-version" an neuen Versionsstring angepasst.
[ngircd-alex.git] / src / ngircd / Makefile.am
index 1bc53ac1718444968dd20298a49919f1236839a3..c7441b379e89fdab0547389bc963cb650f92ebc9 100644 (file)
@@ -9,22 +9,28 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.19 2002/03/29 22:52:12 alex Exp $
+# $Id: Makefile.am,v 1.27 2002/09/07 18:06:29 alex Exp $
 #
 
-AM_CFLAGS = -I$(srcdir)/../portab
+AUTOMAKE_OPTIONS = ../portab/ansi2knr
+
+INCLUDES = -I$(srcdir)/../portab
 
 LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
 
 sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
-       irc-channel.c irc-login.c irc-mode.c irc-oper.c irc-server.c \
-       irc-write.c log.c parse.c tool.c
+       irc-channel.c irc-login.c irc-mode.c irc-op.c irc-oper.c irc-server.c \
+       irc-write.c lists.c log.c match.c parse.c resolve.c tool.c
+
+ngircd_LDFLAGS = -L../portab
+
+ngircd_LDADD = -lngportab
 
 noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
-       irc-channel.h irc-login.h irc-mode.h irc-oper.h irc-server.h \
-       irc-write.h log.h parse.h tool.h \
+       irc-channel.h irc-login.h irc-mode.h irc-op.h irc-oper.h irc-server.h \
+       irc-write.h lists.h log.h match.h parse.h resolve.h tool.h \
        messages.h defines.h
 
 clean-local:
@@ -35,7 +41,7 @@ maintainer-clean-local:
 
 check-version: Makefile
        echo "#!/bin/sh" > check-version
-       echo "./ngircd --version | grep version > /dev/null 2>&1" >> check-version
+       echo "./ngircd --version | grep ngircd > /dev/null 2>&1" >> check-version
        chmod 755 check-version
 
 check-help: Makefile
@@ -47,7 +53,7 @@ lint:
        rm -f lint.out
        for f in *.c; do \
         echo "checking $$f ..."; \
-        splint $$f $(LINTARGS) -I./.. $(AM_CFLAGS) > lint.out 2>&1; \
+        splint $$f $(LINTARGS) -I./.. -I./../portab $(AM_CFLAGS) > lint.out 2>&1; \
         grep "no warnings" lint.out > /dev/null 2>&1; \
         if [ $$? -ne 0 ]; then \
          echo; cat lint.out; echo; \