]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- Auf Systemen, die "sys/select.h" kennen (z.B. AIX 3.2.5) wird dieses nun includiert.
[ngircd-alex.git] / src / ngircd / Makefile.am
index 099e23291dafa9d511ed20af2c38e39f38786649..c7441b379e89fdab0547389bc963cb650f92ebc9 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.25 2002/06/26 15:44:47 alex Exp $
+# $Id: Makefile.am,v 1.27 2002/09/07 18:06:29 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -41,7 +41,7 @@ maintainer-clean-local:
 
 check-version: Makefile
        echo "#!/bin/sh" > check-version
-       echo "./ngircd --version | grep version > /dev/null 2>&1" >> check-version
+       echo "./ngircd --version | grep ngircd > /dev/null 2>&1" >> check-version
        chmod 755 check-version
 
 check-help: Makefile
@@ -53,7 +53,7 @@ lint:
        rm -f lint.out
        for f in *.c; do \
         echo "checking $$f ..."; \
-        splint $$f $(LINTARGS) -I./.. $(AM_CFLAGS) > lint.out 2>&1; \
+        splint $$f $(LINTARGS) -I./.. -I./../portab $(AM_CFLAGS) > lint.out 2>&1; \
         grep "no warnings" lint.out > /dev/null 2>&1; \
         if [ $$? -ne 0 ]; then \
          echo; cat lint.out; echo; \