]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
Move "ClientHost" and "ClientUserNick" to end of [Global] section
[ngircd-alex.git] / src / ngircd / Makefile.am
index cfa45e19716ff63299919a66bc7bcb0f8f14ee08..c61766591e33480a5b624731a70fab92f8a73c35 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2003 by Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2010 Alexander Barton (alex@barton.de)
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -8,8 +8,6 @@
 # (at your option) any later version.
 # Please read the file COPYING, README and AUTHORS for more information.
 #
-# $Id: Makefile.am,v 1.51 2008/02/26 22:04:17 fw Exp $
-#
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
 
@@ -21,22 +19,22 @@ LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN \
 sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c array.c channel.c client.c conf.c conn.c conn-func.c \
-       conn-zip.c hash.c io.c irc.c irc-channel.c irc-info.c irc-login.c \
+       conn-ssl.c conn-zip.c hash.c io.c irc.c irc-channel.c irc-info.c irc-login.c \
        irc-mode.c irc-op.c irc-oper.c irc-server.c irc-write.c lists.c log.c \
-       match.c numeric.c parse.c rendezvous.c resolve.c
+       match.c op.c numeric.c pam.c parse.c proc.c resolve.c sighandlers.c
 
 ngircd_LDFLAGS = -L../portab -L../tool -L../ipaddr
 
 ngircd_LDADD = -lngportab -lngtool -lngipaddr
 
-noinst_HEADERS = ngircd.h array.h channel.h client.h conf.h conn.h conn-func.h \
-       conn-zip.h hash.h io.h irc.h irc-channel.h irc-info.h irc-login.h \
-       irc-mode.h irc-op.h irc-oper.h irc-server.h irc-write.h lists.h log.h \
-       match.h numeric.h parse.h rendezvous.h resolve.h \
-       defines.h messages.h
+noinst_HEADERS = ngircd.h array.h channel.h client.h conf.h conf-ssl.h conn.h \
+       conn-func.h conn-ssl.h conn-zip.h hash.h io.h irc.h irc-channel.h \
+       irc-info.h irc-login.h irc-mode.h irc-op.h irc-oper.h irc-server.h \
+       irc-write.h lists.h log.h match.h numeric.h op.h pam.h parse.h proc.h \
+       resolve.h sighandlers.h defines.h messages.h
 
 clean-local:
-       rm -f check-version check-help lint.out cvs-version.*
+       rm -f check-version check-help lint.out
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
@@ -77,23 +75,6 @@ lint:
         || echo "Result: no warnings found."; \
        echo; [ $$warnings -gt 0 ] && exit 1
 
-ngircd.c: cvs-version.h
-
-irc-login.c: cvs-version.h
-
-irc-info.c: cvs-version.h
-
-cvs-version.h: cvs-date
-
-cvs-date:
-       grep VERSION ../config.h | grep "CVS" \
-        && echo "#define CVSDATE \"$$( grep "\$$Id" $(srcdir)/*.c \
-           | $(AWK) "{ print \$$9 }" | sort | tail -1 \
-           | sed -e "s/\//-/g" )\"" > cvs-version.new \
-        || echo "" > cvs-version.new
-       diff cvs-version.h cvs-version.new 2>/dev/null \
-        || cp cvs-version.new cvs-version.h
-
 TESTS = check-version check-help
 
 # -eof-