]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
Move "ClientHost" and "ClientUserNick" to end of [Global] section
[ngircd-alex.git] / src / ngircd / Makefile.am
index 1bc693abde8489aa105bb6dae2dce6bcb71f798d..c61766591e33480a5b624731a70fab92f8a73c35 100644 (file)
@@ -1,73 +1,79 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001,2002 by Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2010 Alexander Barton (alex@barton.de)
 #
-# Dieses Programm ist freie Software. Sie koennen es unter den Bedingungen
-# der GNU General Public License (GPL), wie von der Free Software Foundation
-# herausgegeben, weitergeben und/oder modifizieren, entweder unter Version 2
-# der Lizenz oder (wenn Sie es wuenschen) jeder spaeteren Version.
-# Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
-# der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
-#
-# $Id: Makefile.am,v 1.28 2002/10/07 21:16:13 alex Exp $
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+# Please read the file COPYING, README and AUTHORS for more information.
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
 
-INCLUDES = -I$(srcdir)/../portab
+INCLUDES = -I$(srcdir)/../portab -I$(srcdir)/../tool -I$(srcdir)/../ipaddr
 
-LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
+LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN \
+ -varuse -retvalother -emptyret -unrecog
 
 sbin_PROGRAMS = ngircd
 
-ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
-       irc-channel.c irc-login.c irc-mode.c irc-op.c irc-oper.c irc-server.c \
-       irc-write.c lists.c log.c match.c parse.c resolve.c tool.c
+ngircd_SOURCES = ngircd.c array.c channel.c client.c conf.c conn.c conn-func.c \
+       conn-ssl.c conn-zip.c hash.c io.c irc.c irc-channel.c irc-info.c irc-login.c \
+       irc-mode.c irc-op.c irc-oper.c irc-server.c irc-write.c lists.c log.c \
+       match.c op.c numeric.c pam.c parse.c proc.c resolve.c sighandlers.c
 
-ngircd_LDFLAGS = -L../portab
+ngircd_LDFLAGS = -L../portab -L../tool -L../ipaddr
 
-ngircd_LDADD = -lngportab
+ngircd_LDADD = -lngportab -lngtool -lngipaddr
 
-noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
-       irc-channel.h irc-login.h irc-mode.h irc-op.h irc-oper.h irc-server.h \
-       irc-write.h lists.h log.h match.h parse.h resolve.h tool.h \
-       messages.h defines.h
+noinst_HEADERS = ngircd.h array.h channel.h client.h conf.h conf-ssl.h conn.h \
+       conn-func.h conn-ssl.h conn-zip.h hash.h io.h irc.h irc-channel.h \
+       irc-info.h irc-login.h irc-mode.h irc-op.h irc-oper.h irc-server.h \
+       irc-write.h lists.h log.h match.h numeric.h op.h pam.h parse.h proc.h \
+       resolve.h sighandlers.h defines.h messages.h
 
 clean-local:
-       rm -f check-version check-help lint.out cvs-version.*
+       rm -f check-version check-help lint.out
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
 check-version: Makefile
        echo "#!/bin/sh" > check-version
-       echo "./ngircd --version | grep ngircd > /dev/null 2>&1" >> check-version
+       echo "./ngircd --version | grep ngircd >/dev/null 2>&1" >>check-version
        chmod 755 check-version
 
 check-help: Makefile
        echo "#!/bin/sh" > check-help
-       echo "./ngircd --help | grep help > /dev/null 2>&1" >> check-help
+       echo "./ngircd --help | grep help >/dev/null 2>&1" >>check-help
        chmod 755 check-help
 
 lint:
-       rm -f lint.out
+       @splint --version >/dev/null 2>&1 \
+        || ( echo; echo "Error: \"splint\" not found!"; echo; exit 1 )
+       @echo; warnings=0; files=0; \
        for f in *.c; do \
         echo "checking $$f ..."; \
-        splint $$f $(LINTARGS) -I./.. -I./../portab $(AM_CFLAGS) > lint.out 2>&1; \
+        splint $$f $(LINTARGS) -I$(srcdir) -I$(srcdir)/.. \
+         $(INCLUDES) $(AM_CFLAGS) >lint.out 2>&1; \
         grep "no warnings" lint.out > /dev/null 2>&1; \
         if [ $$? -ne 0 ]; then \
-         echo; cat lint.out; echo; \
+         waswarning=1; \
+         echo; grep -v "^Command Line: " lint.out; echo; \
+         w=$$( grep "code warning" lint.out | $(AWK) "{ print \$$4 }" ); \
+         [ "$$w" -gt 0 ] && warnings=`expr $$warnings + $$w`; \
+         files=`expr $$files + 1`; \
+        else \
+         waswarning=0; \
         fi; \
-       done;
-
-ngircd.c: cvs-date cvs-version.h
-
-cvs-date:
-       grep VERSION $(srcdir)/../config.h | grep "CVS" \
-        && echo "#define CVSDATE \"$$( grep "\$$Id" *.c *.h | awk "{ print \$$6 }" | sort | tail -n 1 )\"" > $(srcdir)/cvs-version.new \
-        || echo "" > $(srcdir)/cvs-version.new
-       diff $(srcdir)/cvs-version.h $(srcdir)/cvs-version.new \
-        || cp $(srcdir)/cvs-version.new $(srcdir)/cvs-version.h
+        rm -f lint.out; \
+       done; \
+       [ $$waswarning -eq 0 ] && echo; \
+       [ $$warnings -gt 0 ] \
+        && echo "Result: $$warnings warning(s) in $$files file(s)!" \
+        || echo "Result: no warnings found."; \
+       echo; [ $$warnings -gt 0 ] && exit 1
 
 TESTS = check-version check-help