]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- Fehler-Ausgaben verbessert (Prefix-Fehler).
[ngircd-alex.git] / src / ngircd / Makefile.am
index 099e23291dafa9d511ed20af2c38e39f38786649..c3a130445bd21d185b603ba13763fd0803836078 100644 (file)
@@ -9,7 +9,7 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.25 2002/06/26 15:44:47 alex Exp $
+# $Id: Makefile.am,v 1.29 2002/10/08 18:30:03 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -34,14 +34,14 @@ noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
        messages.h defines.h
 
 clean-local:
-       rm -f check-version check-help lint.out
+       rm -f check-version check-help lint.out cvs-version.*
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
 check-version: Makefile
        echo "#!/bin/sh" > check-version
-       echo "./ngircd --version | grep version > /dev/null 2>&1" >> check-version
+       echo "./ngircd --version | grep ngircd > /dev/null 2>&1" >> check-version
        chmod 755 check-version
 
 check-help: Makefile
@@ -53,13 +53,22 @@ lint:
        rm -f lint.out
        for f in *.c; do \
         echo "checking $$f ..."; \
-        splint $$f $(LINTARGS) -I./.. $(AM_CFLAGS) > lint.out 2>&1; \
+        splint $$f $(LINTARGS) -I./.. -I./../portab $(AM_CFLAGS) > lint.out 2>&1; \
         grep "no warnings" lint.out > /dev/null 2>&1; \
         if [ $$? -ne 0 ]; then \
          echo; cat lint.out; echo; \
         fi; \
        done;
 
+ngircd.c: cvs-date cvs-version.h
+
+cvs-date:
+       grep VERSION ../config.h | grep "CVS" \
+        && echo "#define CVSDATE \"$$( grep "\$$Id" $(srcdir)/*.c $(srcdir)/*.h \
+           | awk "{ print \$$6 }" | sort | tail -n 1 )\"" > cvs-version.new \
+        || echo "" > cvs-version.new
+       diff cvs-version.h cvs-version.new || cp cvs-version.new cvs-version.h
+
 TESTS = check-version check-help
 
 # -eof-