]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
Debian: require "telnet" or "telnet-ssl" for building
[ngircd-alex.git] / src / ngircd / Makefile.am
index f5a7d83463f0fa46e26b19ca5f087e05731d9a65..c1fd42409dbb1b24b57492e6dc9e9d161ca8c481 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2003 by Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2012 Alexander Barton (alex@barton.de)
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # (at your option) any later version.
 # Please read the file COPYING, README and AUTHORS for more information.
 #
-# $Id: Makefile.am,v 1.44 2005/04/09 12:30:55 alex Exp $
-#
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
 
-INCLUDES = -I$(srcdir)/../portab -I$(srcdir)/../tool
+INCLUDES = -I$(srcdir)/../portab -I$(srcdir)/../tool -I$(srcdir)/../ipaddr
 
 LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN \
- -varuse -retvalother -emptyret
+ -varuse -retvalother -emptyret -unrecog
 
 sbin_PROGRAMS = ngircd
 
-ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c conn-zip.c conn-func.c \
-       hash.c irc.c irc-channel.c irc-info.c irc-login.c irc-mode.c irc-op.c \
-       irc-oper.c irc-server.c irc-write.c lists.c log.c match.c parse.c \
-       rendezvous.c resolve.c
-
-ngircd_LDFLAGS = -L../portab -L../tool
-
-ngircd_LDADD = -lngportab -lngtool
-
-noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h conn-zip.h conn-func.h \
-       hash.h irc.h irc-channel.h irc-info.h irc-login.h irc-mode.h irc-op.h \
-       irc-oper.h irc-server.h irc-write.h lists.h log.h match.h parse.h \
-       rendezvous.h resolve.h \
-       messages.h defines.h
+ngircd_SOURCES = \
+       ngircd.c \
+       array.c \
+       channel.c \
+       class.c \
+       client.c \
+       client-cap.c \
+       conf.c \
+       conn.c \
+       conn-encoding.c \
+       conn-func.c \
+       conn-ssl.c \
+       conn-zip.c \
+       hash.c \
+       io.c \
+       irc.c \
+       irc-cap.c \
+       irc-channel.c \
+       irc-encoding.c \
+       irc-info.c \
+       irc-login.c \
+       irc-mode.c \
+       irc-op.c \
+       irc-oper.c \
+       irc-server.c \
+       irc-write.c \
+       lists.c \
+       log.c \
+       login.c \
+       match.c \
+       numeric.c \
+       op.c \
+       pam.c \
+       parse.c \
+       proc.c \
+       resolve.c \
+       sighandlers.c
+
+ngircd_LDFLAGS = -L../portab -L../tool -L../ipaddr
+
+ngircd_LDADD = -lngportab -lngtool -lngipaddr
+
+noinst_HEADERS = \
+       ngircd.h \
+       array.h \
+       channel.h \
+       class.h \
+       client.h \
+       client-cap.h \
+       conf.h \
+       conf-ssl.h \
+       conn.h \
+       conn-encoding.h \
+       conn-func.h \
+       conn-ssl.h \
+       conn-zip.h \
+       defines.h \
+       hash.h \
+       io.h \
+       irc.h \
+       irc-cap.h \
+       irc-channel.h \
+       irc-encoding.h \
+       irc-info.h \
+       irc-login.h \
+       irc-mode.h \
+       irc-op.h \
+       irc-oper.h \
+       irc-server.h \
+       irc-write.h \
+       lists.h \
+       log.h \
+       login.h \
+       match.h \
+       messages.h \
+       numeric.h \
+       op.h \
+       pam.h \
+       parse.h \
+       proc.h \
+       resolve.h \
+       sighandlers.h
 
 clean-local:
-       rm -f check-version check-help lint.out cvs-version.*
+       rm -f check-version check-help lint.out
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
 check-version: Makefile
        echo "#!/bin/sh" > check-version
-       echo "./ngircd --version | grep ngircd > /dev/null 2>&1" >> check-version
+       echo "./ngircd --version | grep ngircd >/dev/null 2>&1" >>check-version
        chmod 755 check-version
 
 check-help: Makefile
        echo "#!/bin/sh" > check-help
-       echo "./ngircd --help | grep help > /dev/null 2>&1" >> check-help
+       echo "./ngircd --help | grep help >/dev/null 2>&1" >>check-help
        chmod 755 check-help
 
 lint:
@@ -63,8 +129,8 @@ lint:
         if [ $$? -ne 0 ]; then \
          waswarning=1; \
          echo; grep -v "^Command Line: " lint.out; echo; \
-         w=$$( grep "code warning" lint.out | awk "{ print \$$4 }" ); \
-         warnings=`expr $$warnings + $$w`; \
+         w=$$( grep "code warning" lint.out | $(AWK) "{ print \$$4 }" ); \
+         [ "$$w" -gt 0 ] && warnings=`expr $$warnings + $$w`; \
          files=`expr $$files + 1`; \
         else \
          waswarning=0; \
@@ -77,23 +143,6 @@ lint:
         || echo "Result: no warnings found."; \
        echo; [ $$warnings -gt 0 ] && exit 1
 
-ngircd.c: cvs-version.h
-
-irc-login.c: cvs-version.h
-
-irc-info.c: cvs-version.h
-
-cvs-version.h: cvs-date
-
-cvs-date:
-       grep VERSION ../config.h | grep "CVS" \
-        && echo "#define CVSDATE \"$$( grep "\$$Id" $(srcdir)/*.c \
-           | $(AWK) "{ print \$$9 }" | sort | tail -1 \
-           | sed -e "s/\//-/g" )\"" > cvs-version.new \
-        || echo "" > cvs-version.new
-       diff cvs-version.h cvs-version.new 2>/dev/null \
-        || cp cvs-version.new cvs-version.h
-
 TESTS = check-version check-help
 
 # -eof-