]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- JOIN: Invite- und Ban-Lists werden nun beachtet.
[ngircd-alex.git] / src / ngircd / Makefile.am
index 7b42f5ceb2dfd35d3bec13cfb6ae4c6e83fc23ca..a2d7365a177fac20810a140888888ef78e040e01 100644 (file)
@@ -9,9 +9,11 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.20 2002/05/19 01:15:55 alex Exp $
+# $Id: Makefile.am,v 1.23 2002/05/27 11:25:17 alex Exp $
 #
 
+AUTOMAKE_OPTIONS = ../portab/ansi2knr
+
 AM_CFLAGS = -I$(srcdir)/../portab
 
 LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
@@ -19,14 +21,16 @@ LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
 sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
-       irc-channel.c irc-login.c irc-mode.c irc-oper.c irc-server.c \
-       irc-write.c log.c parse.c tool.c
+       irc-channel.c irc-login.c irc-mode.c irc-op.c irc-oper.c irc-server.c \
+       irc-write.c lists.c log.c parse.c resolve.c tool.c
+
+ngircd_LDFLAGS = -L../portab
 
-ngircd_LDFLAGS = -L../portab -lngportab
+ngircd_LDADD = -lngportab
 
 noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
-       irc-channel.h irc-login.h irc-mode.h irc-oper.h irc-server.h \
-       irc-write.h log.h parse.h tool.h \
+       irc-channel.h irc-login.h irc-mode.h irc-op.h irc-oper.h irc-server.h \
+       irc-write.h lists.h log.h parse.h resolve.h tool.h \
        messages.h defines.h
 
 clean-local: