]> arthur.barton.de Git - ngircd-alex.git/blobdiff - doc/Makefile.am
Update NEWS and ChangeLog files
[ngircd-alex.git] / doc / Makefile.am
index 3a37ff4768153ed5badcbfa76435417406ebd678..c153fece01813cc61955fdfc20846ed08f579f4f 100644 (file)
@@ -1,36 +1,54 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2008 Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2011 Alexander Barton (alex@barton.de) and Contributors
 #
-# Dieses Programm ist freie Software. Sie koennen es unter den Bedingungen
-# der GNU General Public License (GPL), wie von der Free Software Foundation
-# herausgegeben, weitergeben und/oder modifizieren, entweder unter Version 2
-# der Lizenz oder (wenn Sie es wuenschen) jeder spaeteren Version.
-# Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
-# der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+# Please read the file COPYING, README and AUTHORS for more information.
 #
 
+.tmpl:
+       sed \
+           -e s@:ETCDIR:@${sysconfdir}@ \
+           <$< >$@
+
+SUFFIXES = .tmpl
+
+static_docs = Bopm.txt FAQ.txt GIT.txt HowToRelease.txt Modes.txt PAM.txt \
+       Platforms.txt Protocol.txt README-AUX.txt README-BeOS.txt \
+       README-Interix.txt RFC.txt SSL.txt Services.txt
+
+doc_templates = sample-ngircd.conf.tmpl
+
+generated_docs = sample-ngircd.conf
+
+toplevel_docs = ../AUTHORS ../COPYING ../ChangeLog ../INSTALL ../NEWS ../README
+
 SUBDIRS = src
 
-EXTRA_DIST = FAQ.txt GIT.txt Protocol.txt Platforms.txt README-AUX.txt \
-       README-BeOS.txt RFC.txt Services.txt SSL.txt Zeroconf.txt \
-       sample-ngircd.conf
+EXTRA_DIST = $(static_docs) $(doc_templates)
+
+CLEANFILES = $(generated_docs)
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
-documents = $(EXTRA_DIST) ../AUTHORS ../COPYING ../ChangeLog ../INSTALL \
-       ../NEWS ../README
+all: $(generated_docs)
 
-install-data-hook:
+install-data-hook: $(static_docs) $(toplevel_docs) $(generated_docs)
        $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
        if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
-         $(INSTALL) -m 600 -c $(srcdir)/sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; \
+         $(INSTALL) -m 600 -c sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; \
         fi
        $(mkinstalldirs) $(DESTDIR)$(docdir)
-       for f in $(documents); do \
+       for f in $(static_docs) $(toplevel_docs); do \
          $(INSTALL) -m 644 -c $(srcdir)/$$f $(DESTDIR)$(docdir)/; \
         done
+       for f in $(generated_docs); do \
+         $(INSTALL) -m 644 -c $$f $(DESTDIR)$(docdir)/; \
+        done
 
 uninstall-hook:
        rm -rf $(DESTDIR)$(docdir)