]> arthur.barton.de Git - ngircd-alex.git/blobdiff - doc/Makefile.am
Streamline the "testsuite" and "srcdoc" make targets
[ngircd-alex.git] / doc / Makefile.am
index 5913c94ee1fdd05fbd34808c80d3e11646e79cb3..91583f5c1f5267e1fcfbe89ea53af606832327ed 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2015 Alexander Barton (alex@barton.de) and Contributors
+# Copyright (c)2001-2024 Alexander Barton (alex@barton.de) and Contributors
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -22,7 +22,7 @@ static_docs = \
        Capabilities.txt \
        Commands.txt \
        Contributing.txt \
-       FAQ.txt \
+       FAQ.md \
        HowToRelease.txt \
        Modes.txt \
        PAM.txt \
@@ -39,7 +39,7 @@ doc_templates = sample-ngircd.conf.tmpl
 
 generated_docs = sample-ngircd.conf
 
-toplevel_docs = ../AUTHORS ../COPYING ../ChangeLog ../INSTALL ../NEWS ../README
+toplevel_docs = ../AUTHORS.md ../COPYING ../ChangeLog ../INSTALL.md ../NEWS ../README.md
 
 SUBDIRS = src
 
@@ -55,7 +55,7 @@ all: $(generated_docs)
 install-data-hook: $(static_docs) $(toplevel_docs) $(generated_docs)
        $(MKDIR_P) -m 755 $(DESTDIR)$(sysconfdir)
        @if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
-         make install-config; \
+         ${MAKE} install-config; \
         fi
        $(MKDIR_P) -m 755 $(DESTDIR)$(docdir)
        for f in $(static_docs) $(toplevel_docs); do \
@@ -75,7 +75,7 @@ install-config:
 uninstall-hook:
        rm -rf $(DESTDIR)$(docdir)
        @if cmp --silent sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; then \
-         make uninstall-config; \
+         ${MAKE} uninstall-config; \
         else \
          echo; \
          echo " ** NOTE: Not uninstalling changed configuration file:"; \
@@ -86,9 +86,6 @@ uninstall-hook:
 uninstall-config:
        rm -f $(DESTDIR)$(sysconfdir)/ngircd.conf
 
-srcdoc:
-       make -C src srcdoc
-
-.PHONY: install-config uninstall-config srcdoc
+.PHONY: install-config uninstall-config
 
 # -eof-