]> arthur.barton.de Git - ngircd-alex.git/blobdiff - doc/Makefile.am
Makefile.am: Replace make with ${MAKE} (#270)
[ngircd-alex.git] / doc / Makefile.am
index 04f74b6059acd132336f5527477d533297c6989a..4ce26f06bfb09353da98b28467f0b8f875a74227 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2013 Alexander Barton (alex@barton.de) and Contributors
+# Copyright (c)2001-2020 Alexander Barton (alex@barton.de) and Contributors
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -23,7 +23,6 @@ static_docs = \
        Commands.txt \
        Contributing.txt \
        FAQ.txt \
-       GIT.txt \
        HowToRelease.txt \
        Modes.txt \
        PAM.txt \
@@ -40,7 +39,7 @@ doc_templates = sample-ngircd.conf.tmpl
 
 generated_docs = sample-ngircd.conf
 
-toplevel_docs = ../AUTHORS ../COPYING ../ChangeLog ../INSTALL ../NEWS ../README
+toplevel_docs = ../AUTHORS ../COPYING ../ChangeLog ../INSTALL.md ../NEWS ../README.md
 
 SUBDIRS = src
 
@@ -54,11 +53,11 @@ maintainer-clean-local:
 all: $(generated_docs)
 
 install-data-hook: $(static_docs) $(toplevel_docs) $(generated_docs)
-       $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+       $(MKDIR_P) -m 755 $(DESTDIR)$(sysconfdir)
        @if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
-         make install-config; \
+         ${MAKE} install-config; \
         fi
-       $(mkinstalldirs) $(DESTDIR)$(docdir)
+       $(MKDIR_P) -m 755 $(DESTDIR)$(docdir)
        for f in $(static_docs) $(toplevel_docs); do \
          $(INSTALL) -m 644 -c $(srcdir)/$$f $(DESTDIR)$(docdir)/; \
         done
@@ -76,7 +75,7 @@ install-config:
 uninstall-hook:
        rm -rf $(DESTDIR)$(docdir)
        @if cmp --silent sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; then \
-         make uninstall-config; \
+         ${MAKE} uninstall-config; \
         else \
          echo; \
          echo " ** NOTE: Not uninstalling changed configuration file:"; \
@@ -88,7 +87,7 @@ uninstall-config:
        rm -f $(DESTDIR)$(sysconfdir)/ngircd.conf
 
 srcdoc:
-       make -C src srcdoc
+       ${MAKE} -C src srcdoc
 
 .PHONY: install-config uninstall-config srcdoc