]> arthur.barton.de Git - ngircd-alex.git/blobdiff - contrib/MacOSX/Makefile.am
Fix typo: Please not -> Please note
[ngircd-alex.git] / contrib / MacOSX / Makefile.am
index 4ad6242b545e4307f146b860d7e5c3afbace0522..abd799c58c00a36b6d1f1488287fdb23d1a6ec5a 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2004 Alexander Barton <alex@barton.de>
+# Copyright (c)2001-2008 Alexander Barton <alex@barton.de>
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -8,10 +8,45 @@
 # (at your option) any later version.
 # Please read the file COPYING, README and AUTHORS for more information.
 #
-# $Id: Makefile.am,v 1.1 2004/02/29 17:19:43 alex Exp $
-#
+
+SUBDIRS = ngIRCd.xcodeproj ngIRCd.pmdoc
+
+EXTRA_DIST = de.barton.ngircd.plist.tmpl config.h preinstall.sh postinstall.sh
+
+SUFFIXES = .tmpl .
+
+.tmpl:
+       sed \
+           -e s@:SBINDIR:@${sbindir}@ \
+           <$< >$@
+
+install-data-local:
+       [ `uname -s` != "Darwin" ] || make install-sys-darwin
+
+install-sys-darwin:
+       @if [ `id -u` -eq 0 ]; then \
+         make install-sys-darwin-root; \
+       else \
+         echo; \
+         echo " ** NOTE: Not installing with root privileges, so the LaunchDaemon script"; \
+         echo " ** \"/Library/LaunchDaemons/de.barton.ngircd.plist\" can't be installed/updated!"; \
+         echo; \
+       fi
+
+install-sys-darwin-root: de.barton.ngircd.plist
+       install -d -m 755 -o root -g wheel $(DESTDIR)/Library/LaunchDaemons
+       install -c -m 644 -b -o root -g wheel de.barton.ngircd.plist \
+        $(DESTDIR)/Library/LaunchDaemons/de.barton.ngircd.plist
+       @echo
+       @echo " ** \"/Library/LaunchDaemons/de.barton.ngircd.plist\" has been installed,"
+       @echo " ** but is disabled. Use launchctl(8) to enable/run ngIRCd on Darwin/Mac OS X."
+       @echo
 
 clean-local:
        rm -rf build
+       rm -f de.barton.ngircd.plist
+
+maintainer-clean-local:
+       rm -f Makefile Makefile.in
 
 # -eof-