]> arthur.barton.de Git - ngircd-alex.git/blobdiff - debian/rules
Updated RPM and Debian package description and configuration.
[ngircd-alex.git] / debian / rules
index a1a21165b446c2449f3394467d28375b7d52e136..f411a377bbd03cc4d3bae886139b923061e9ed1d 100644 (file)
@@ -1,7 +1,17 @@
 #!/usr/bin/make -f
+#
+# ngIRCd -- The Next Generation IRC Daemon
+# Copyright (c)2001-2003 by Alexander Barton (alex@barton.de)
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+# Please read the file COPYING, README and AUTHORS for more information.
+#
 # debian/rules for ngIRCd
 #
-# $Id: rules,v 1.1 2003/07/09 20:23:35 alex Exp $
+# $Id: rules,v 1.2 2003/11/29 20:29:09 alex Exp $
 #
 # Based on the sample debian/rules that uses debhelper,
 # GNU copyright 1997 to 1999 by Joey Hess.
@@ -12,8 +22,8 @@
 
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 CFLAGS = -Wall -g
 
@@ -28,14 +38,17 @@ endif
 
 config.status: configure
        dh_testdir
+
        # Add here commands to configure the package.
        ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
-         --prefix=/usr --sysconfdir=/etc/ngircd --mandir=\$${prefix}/share/man \
+         --prefix=/usr \
+         --sysconfdir=/etc/ngircd \
+         --mandir=\$${prefix}/share/man \
          --with-syslog --with-zlib
 
 build: build-stamp
 
-build-stamp:  config.status
+build-stamp: config.status
        dh_testdir
 
        # Add here commands to compile the package.
@@ -50,6 +63,7 @@ clean:
 
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
+
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
 endif
@@ -66,11 +80,12 @@ install: build
 
        # Add here commands to install the package into debian/ngircd.
        $(MAKE) install DESTDIR=$(CURDIR)/debian/ngircd
-
+       rm -f $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/INSTALL*
+       rm -f $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/COPYING*
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
+       # We have nothing to do by default.
 
 # Build architecture-dependent files here.
 binary-arch: build install
@@ -81,7 +96,7 @@ binary-arch: build install
        dh_installinit
        dh_strip
        dh_compress
-       dh_fixperms -Xetc/ngircd.conf
+       dh_fixperms
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
@@ -89,6 +104,7 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
+
 .PHONY: build clean binary-indep binary-arch binary install 
 
 # -eof-