]> arthur.barton.de Git - netdata.git/blob - netdata-9999.ebuild
added new files to makefiles
[netdata.git] / netdata-9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools git-2 user
8
9 DESCRIPTION="Linux real time system monitoring, over the web!"
10 HOMEPAGE="https://github.com/firehol/netdata"
11 EGIT_REPO_URI="https://github.com/firehol/netdata"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="nfacct +zlib"
17
18 RDEPEND="zlib? ( sys-libs/zlib )
19         nfacct? (
20                 net-firewall/nfacct
21                 net-libs/libmnl
22         )"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig"
25
26 pkg_setup() {
27         enewgroup netdata
28         enewuser netdata -1 -1 / netdata
29 }
30
31 src_prepare() {
32         eautoreconf
33 }
34
35 src_configure() {
36         econf \
37                 --localstatedir="${EROOT}var" \
38                 $(use_enable nfacct plugin-nfacct) \
39                 $(use_with zlib) \
40                 --with-user=netdata
41 }
42
43 src_install() {
44         default
45         fowners netdata /var/log/netdata
46         rm -fr "${ED}/var/cache/netdata"
47 }