debian-base: "telnet-ssl" is no longer available on Debian 10
authorAlexander Barton <alex@barton.de>
Thu, 28 May 2020 12:55:42 +0000 (14:55 +0200)
committerAlexander Barton <alex@barton.de>
Thu, 28 May 2020 12:55:45 +0000 (14:55 +0200)
So only install it on Debian < 10 systems, and install "telnet" on
Debian >= 10 ...

roles/debian-base/tasks/main.yml

index 199cf46d72388a18754a293ab0ee3ad50a7cc7f5..38b56193402657c85ba4b6b0723a280bda848b79 100644 (file)
       'net-tools',
       'screen',
       'sudo',
-      'telnet-ssl',
       'vim',
     ]
 
+- name: install common packages for Debian <10
+  tags:
+    - packages
+  apt:
+    state: present
+    name: [
+      'telnet-ssl',
+    ]
+  when: "ansible_distribution_major_version|int < 10"
+
+- name: install common packages for Debian >= 10
+  tags:
+    - packages
+  apt:
+    state: present
+    name: [
+      'telnet',
+    ]
+  when: "ansible_distribution_major_version|int >= 10"
+
 - name: install common packages (non Proxmox-VE hosts)
   tags:
     - packages