]> arthur.barton.de Git - netatalk.git/blobdiff - include/atalk/Makefile.am
Writing metadata xattr on directories with sticky bit set, FR#94
[netatalk.git] / include / atalk / Makefile.am
index f1cf185970a59a2471838ab9b9248232842a429f..550741d6b473d7f7dd230343b165823ab6871485 100644 (file)
@@ -1,6 +1,8 @@
 # Makefile.am for include/atalk/
 
 atalkincludedir = $(includedir)/atalk
+BUILT_SOURCES = 
+CLEANFILES =
 
 atalkinclude_HEADERS = \
        adouble.h \
@@ -15,29 +17,43 @@ atalkinclude_HEADERS = \
        ea.h \
        acl.h \
        unix.h \
-       volume.h
+       volume.h \
+       standards.h \
+       bstrlib.h \
+       list.h \
+       globals.h \
+       compat.h \
+       uam.h \
+       iniparser.h \
+       dictionary.h \
+       hash.h
 
 noinst_HEADERS = \
        directory.h \
-       hash.h \
        uuid.h \
        queue.h \
        server_child.h \
        server_ipc.h \
        tdb.h \
-       uam.h \
-       cnid_dbd_private.h \
+       cnid_bdb_private.h \
+       cnid_mysql_private.h \
        cnid_private.h \
        bstradd.h \
-       bstrlib.h \
        errchk.h \
        ftw.h \
-       compat.h \
        dsi.h \
        ldapconfig.h \
-       list.h \
-       globals.h \
+       talloc.h \
+       dalloc.h \
+       byteorder.h \
        fce_api.h \
-       standards.h \
-       iniparser.h \
-       dictionary.h
+       spotlight.h
+
+EXTRA_DIST = afp_dtrace.d
+
+if WITH_DTRACE
+BUILT_SOURCES += afp_dtrace.h
+CLEANFILES += afp_dtrace.h
+afp_dtrace.h: $(top_srcdir)/include/atalk/afp_dtrace.d
+       $(LIBTOOL) --mode=execute dtrace -o afp_dtrace.h -h -s $(top_srcdir)/include/atalk/afp_dtrace.d
+endif