]> arthur.barton.de Git - ngircd.git/blobdiff - src/ngircd/Makefile.am
Get rid of cvs-version.* and CVSDATE definition.
[ngircd.git] / src / ngircd / Makefile.am
index cfa45e19716ff63299919a66bc7bcb0f8f14ee08..1a5119f29853382625a06297043581ca0a9c4875 100644 (file)
@@ -36,7 +36,7 @@ noinst_HEADERS = ngircd.h array.h channel.h client.h conf.h conn.h conn-func.h \
        defines.h messages.h
 
 clean-local:
-       rm -f check-version check-help lint.out cvs-version.*
+       rm -f check-version check-help lint.out
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
@@ -77,23 +77,6 @@ lint:
         || echo "Result: no warnings found."; \
        echo; [ $$warnings -gt 0 ] && exit 1
 
-ngircd.c: cvs-version.h
-
-irc-login.c: cvs-version.h
-
-irc-info.c: cvs-version.h
-
-cvs-version.h: cvs-date
-
-cvs-date:
-       grep VERSION ../config.h | grep "CVS" \
-        && echo "#define CVSDATE \"$$( grep "\$$Id" $(srcdir)/*.c \
-           | $(AWK) "{ print \$$9 }" | sort | tail -1 \
-           | sed -e "s/\//-/g" )\"" > cvs-version.new \
-        || echo "" > cvs-version.new
-       diff cvs-version.h cvs-version.new 2>/dev/null \
-        || cp cvs-version.new cvs-version.h
-
 TESTS = check-version check-help
 
 # -eof-