]> arthur.barton.de Git - netdata.git/blobdiff - src/Makefile.am
self-cleaning obsolete cgroups and network interfaces from memory; fixes #1163; fixes...
[netdata.git] / src / Makefile.am
index 921b26e5e6e90fd49fac4e9a7f2a0031f48ff947..3e6a79c191fe5e05e44941625eedcaab35697d54 100644 (file)
@@ -39,7 +39,7 @@ netdata_SOURCES = \
        dictionary.c dictionary.h \
        eval.c eval.h \
        global_statistics.c global_statistics.h \
-       health.c health.h \
+       health.c health.h health_log.c health_config.c health_json.c \
        inlined.h \
        log.c log.h \
        main.c main.h \
@@ -65,10 +65,23 @@ netdata_SOURCES = \
        registry_db.c \
        registry_log.c \
        rrd.c rrd.h \
+       rrddim.c \
+       rrdfamily.c \
+       rrdhost.c \
+       rrdset.c \
+       rrdcalc.c \
+       rrdcalctemplate.c \
+       rrdvar.c \
+       rrddimvar.c \
+       rrdsetvar.c \
        rrd2json.c rrd2json.h \
+       rrd2json_api_old.c rrd2json_api_old.h \
+       rrdpush.c rrdpush.h \
        storage_number.c storage_number.h \
        unit_test.c unit_test.h \
        url.c url.h \
+       web_api_old.c web_api_old.h \
+       web_api_v1.c web_api_v1.h \
        web_buffer.c web_buffer.h \
        web_buffer_svg.c web_buffer_svg.h \
        web_client.c web_client.h \
@@ -135,24 +148,14 @@ apps_plugin_SOURCES = \
        web_buffer.c web_buffer.h \
        $(NULL)
 
+if FREEBSD
+apps_plugin_SOURCES += \
+       plugin_freebsd.h \
+       $(NULL)
+endif
+
 apps_plugin_LDADD = \
        $(OPTIONAL_MATH_LIBS) \
        $(OPTIONAL_CAP_LIBS) \
        $(NULL)
 
-install-data-hook:
-       if [ `id -u` == 0 ]; then \
-               chown root '$(DESTDIR)$(pluginsdir)/apps.plugin' && \
-               chmod 0755 '$(DESTDIR)$(pluginsdir)/apps.plugin' && \
-               ( setcap cap_dac_read_search,cap_sys_ptrace+ep '$(DESTDIR)$(pluginsdir)/apps.plugin' || \
-                 chmod 4755 '$(DESTDIR)$(pluginsdir)/apps.plugin' ); \
-       else \
-               echo; \
-               echo "ATTENTION"; \
-               echo; \
-               echo "$(pluginsdir)/apps.plugin requires escalated capabilities:"; \
-               echo "sudo chown root '$(DESTDIR)$(pluginsdir)/apps.plugin'"; \
-               echo "sudo chmod 0755 '$(DESTDIR)$(pluginsdir)/apps.plugin'"; \
-               echo "sudo setcap cap_dac_read_search,cap_sys_ptrace+ep '$(DESTDIR)$(pluginsdir)/apps.plugin'"; \
-               echo; \
-       fi