]> arthur.barton.de Git - netdata.git/blobdiff - src/Makefile.am
freeipmi.plugin; fixes #1799; fixes #1794; fixes #1309; fixes #1729
[netdata.git] / src / Makefile.am
index bec3ef92d80db15b9264ce6481211bbe781de399..2c672391e3fd1b173a53722a743cb6e7bf28c18c 100644 (file)
@@ -12,6 +12,7 @@ AM_CPPFLAGS = \
        -DRUN_DIR="\"$(localstatedir)/run/netdata\"" \
        -DWEB_DIR="\"$(webdir)\"" \
        $(NULL)
+
 AM_CFLAGS = \
        $(OPTIONAL_MATH_CFLAGS) \
        $(OPTIONAL_NFACCT_CLFAGS) \
@@ -24,8 +25,9 @@ dist_cache_DATA = .keep
 dist_varlib_DATA = .keep
 dist_registry_DATA = .keep
 dist_log_DATA = .keep
+plugins_PROGRAMS =
 if !MACOS
-plugins_PROGRAMS = apps.plugin
+plugins_PROGRAMS += apps.plugin
 endif
 
 netdata_SOURCES = \
@@ -39,7 +41,7 @@ netdata_SOURCES = \
        dictionary.c dictionary.h \
        eval.c eval.h \
        global_statistics.c global_statistics.h \
-       health.c health.h \
+       health.c health.h health_log.c health_config.c health_json.c \
        inlined.h \
        log.c log.h \
        main.c main.h \
@@ -65,10 +67,23 @@ netdata_SOURCES = \
        registry_db.c \
        registry_log.c \
        rrd.c rrd.h \
+       rrddim.c \
+       rrdfamily.c \
+       rrdhost.c \
+       rrdset.c \
+       rrdcalc.c \
+       rrdcalctemplate.c \
+       rrdvar.c \
+       rrddimvar.c \
+       rrdsetvar.c \
        rrd2json.c rrd2json.h \
+       rrd2json_api_old.c rrd2json_api_old.h \
+       rrdpush.c rrdpush.h \
        storage_number.c storage_number.h \
        unit_test.c unit_test.h \
        url.c url.h \
+       web_api_old.c web_api_old.h \
+       web_api_v1.c web_api_v1.h \
        web_buffer.c web_buffer.h \
        web_buffer_svg.c web_buffer_svg.h \
        web_client.c web_client.h \
@@ -146,19 +161,14 @@ apps_plugin_LDADD = \
        $(OPTIONAL_CAP_LIBS) \
        $(NULL)
 
-install-data-hook:
-       if [ `id -u` == 0 ]; then \
-               chown root '$(DESTDIR)$(pluginsdir)/apps.plugin' && \
-               chmod 0755 '$(DESTDIR)$(pluginsdir)/apps.plugin' && \
-               ( setcap cap_dac_read_search,cap_sys_ptrace+ep '$(DESTDIR)$(pluginsdir)/apps.plugin' || \
-                 chmod 4755 '$(DESTDIR)$(pluginsdir)/apps.plugin' ); \
-       else \
-               echo; \
-               echo "ATTENTION"; \
-               echo; \
-               echo "$(pluginsdir)/apps.plugin requires escalated capabilities:"; \
-               echo "sudo chown root '$(DESTDIR)$(pluginsdir)/apps.plugin'"; \
-               echo "sudo chmod 0755 '$(DESTDIR)$(pluginsdir)/apps.plugin'"; \
-               echo "sudo setcap cap_dac_read_search,cap_sys_ptrace+ep '$(DESTDIR)$(pluginsdir)/apps.plugin'"; \
-               echo; \
-       fi
+if FREEIPMI
+plugins_PROGRAMS += freeipmi.plugin
+
+freeipmi_plugin_SOURCES = \
+       freeipmi_plugin.c \
+       $(NULL)
+
+freeipmi_plugin_LDADD = \
+    $(OPTIONAL_IPMIMONITORING_LIBS) \
+       $(NULL)
+endif