]> arthur.barton.de Git - netdata.git/blobdiff - python.d/Makefile.am
preserve configs across installaitons
[netdata.git] / python.d / Makefile.am
index 8c84254b8f93af846b8367939938e9d56b782add..1a43fe07e2465695eacfa8cbd0e0d3e3ca2b374f 100644 (file)
@@ -2,6 +2,7 @@ MAINTAINERCLEANFILES= $(srcdir)/Makefile.in
 
 dist_python_SCRIPTS = \
        example.chart.py \
+       mysql.chart.py \
        $(NULL)
 
 dist_python_DATA = \
@@ -10,4 +11,33 @@ dist_python_DATA = \
 
 pythonmodulesdir=$(pythondir)/python_modules
 dist_pythonmodules_DATA = \
+       python_modules/__init__.py
+       $(NULL)
+
+
+pythonmodulespymysqldir=$(pythondir)/python_modules/pymysql
+dist_pythonmodulespymysql_DATA = \
+       python_modules/pymysql/charset.py \
+       python_modules/pymysql/_compat.py \
+       python_modules/pymysql/connections.py \
+       python_modules/pymysql/converters.py \
+       python_modules/pymysql/cursors.py \
+       python_modules/pymysql/err.py \
+       python_modules/pymysql/__init__.py \
+       python_modules/pymysql/optionfile.py \
+       python_modules/pymysql/_socketio.py \
+       python_modules/pymysql/times.py \
+       python_modules/pymysql/util.py \
+       $(NULL)
+
+pythonmodulespymysqlconstantsdir=$(pythondir)/python_modules/pymysql/constants
+dist_pythonmodulespymysqlconstants_DATA = \
+       python_modules/pymysql/constants/CLIENT.py \
+       python_modules/pymysql/constants/COMMAND.py \
+       python_modules/pymysql/constants/CR.py \
+       python_modules/pymysql/constants/ER.py \
+       python_modules/pymysql/constants/FIELD_TYPE.py \
+       python_modules/pymysql/constants/FLAG.py \
+       python_modules/pymysql/constants/__init__.py \
+       python_modules/pymysql/constants/SERVER_STATUS.py \
        $(NULL)