]> arthur.barton.de Git - ax-debian-repo.git/commitdiff
ax-debian-repo 1 rel-1
authorAlexander Barton <alex@barton.de>
Thu, 30 Oct 2014 12:32:29 +0000 (13:32 +0100)
committerAlexander Barton <alex@barton.de>
Thu, 30 Oct 2014 12:32:29 +0000 (13:32 +0100)
.gitignore [new file with mode: 0644]
AUTHORS [new file with mode: 0644]
COPYING [new file with mode: 0644]
Makefile [new file with mode: 0644]
Makefile.ax [new file with mode: 0644]
README [new file with mode: 0644]
alex-lenny.sources.list [new file with mode: 0644]
ax-debian-repo [new file with mode: 0644]
debian.barton.de.gpg [new file with mode: 0644]
debian/changelog [new file with mode: 0644]

diff --git a/.gitignore b/.gitignore
new file mode 100644 (file)
index 0000000..3bb4649
--- /dev/null
@@ -0,0 +1,4 @@
+ax-debian-repo_*.dsc
+ax-debian-repo_*.tar.gz
+ax-debian-repo_*_all.deb
+ax-debian-repo_*_*.changes
diff --git a/AUTHORS b/AUTHORS
new file mode 100644 (file)
index 0000000..9ebacba
--- /dev/null
+++ b/AUTHORS
@@ -0,0 +1 @@
+Alexander Barton <alex@barton.de>
diff --git a/COPYING b/COPYING
new file mode 100644 (file)
index 0000000..df45dc3
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,17 @@
+Copyright 2014 by Alexander Barton <alex@barton.de>
+
+The files in this package are free software; you can redistribute them
+and/or modify them under the terms of the GNU General Public License
+as published by the Free Software Foundation; either version 2, or (at
+your option) any later version.
+
+The files in this package are distributed in the hope that they will
+be useful, but WITHOUT ANY WARRANTY; without even the implied warranty
+of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+with your Debian GNU/Linux system, in /usr/share/common-licenses/GPL,
+or with the Debian GNU/Linux bash source package as the file COPYING.
+If not, write to the Free Software Foundation, Inc., 51 Franklin St,
+Fifth Floor, Boston, MA 02110-1301, USA.
diff --git a/Makefile b/Makefile
new file mode 100644 (file)
index 0000000..f25d294
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+#
+# Makefile
+#
+
+SUBDIRS = 
+
+all-local:
+       equivs-build --full ax-debian-repo
+
+clean-local:
+       rm -f ax-debian-repo_*.dsc ax-debian-repo_*.tar.gz \
+        ax-debian-repo_*_all.deb ax-debian-repo_*_amd64.changes
+
+include ./Makefile.ax
diff --git a/Makefile.ax b/Makefile.ax
new file mode 100644 (file)
index 0000000..180ce3c
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# ax-make: Alex' Simple Makefile System
+# Copyright (c)2014 Alexander Barton (alex@barton.de)
+#
+# This library is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published
+# by the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+
+AX_SILENT ?= @
+
+PREFIX ?= /usr/local
+
+USER ?= $(shell id -un)
+GROUP ?= $(shell stat --format=%G $(DESTDIR)$(PREFIX) 2>/dev/null || id -gn)
+
+all: all-ax all-local
+
+all-ax: $(ALL) $(SUBDIRS)
+
+clean: clean-ax clean-local
+
+distclean: clean-local distclean-ax distclean-local
+
+maintainer-clean: clean-local distclean-local maintainer-clean-ax maintainer-clean-local
+
+check: check-pre check-ax check-local check-post
+
+install: install-ax install-local
+
+all-ax clean-ax distclean-ax maintainer-clean-ax check-ax install-ax:
+       $(AX_SILENT)for subdir in $(SUBDIRS); do \
+         target=`echo "$@" | sed -e 's/-ax$$//'`; \
+         echo "Making \"$$target\" in \"$$subdir\" ..."; \
+         $(MAKE) -C $$subdir $$target || exit 1; \
+        done
+
+.PHONY: all clean distclean maintainer-clean check install
+.PHONY: all-ax clean-ax distclean-ax maintainer-clean-ax check-ax install-ax
+.PHONY: all-local clean-local distclean-local maintainer-clean-local check-local install-local
+.PHONY: check-pre check-post
+.PHONY: $(SUBDIRS)
diff --git a/README b/README
new file mode 100644 (file)
index 0000000..c20b37c
--- /dev/null
+++ b/README
@@ -0,0 +1,4 @@
+@packagename@
+
+This package configures the system to include Alex' own Debian package
+repository and the required GnuPG key.
diff --git a/alex-lenny.sources.list b/alex-lenny.sources.list
new file mode 100644 (file)
index 0000000..e62cc7f
--- /dev/null
@@ -0,0 +1,7 @@
+# /etc/apt/sources.list.d/alex-lenny.sources.list
+# 2014-09-28, alex@pingnet.de
+
+deb http://debian.barton.de/debian/ lenny main contrib non-free
+deb-src http://debian.barton.de/debian/ lenny main contrib non-free
+
+# -eof-
diff --git a/ax-debian-repo b/ax-debian-repo
new file mode 100644 (file)
index 0000000..f10d1b8
--- /dev/null
@@ -0,0 +1,22 @@
+Source: ax-debian-repo
+Section: misc
+Priority: optional
+Homepage: http://debian.barton.de/
+Standards-Version: 3.9.2
+
+Package: ax-debian-repo
+Maintainer: Alexander Barton <alex@barton.de>
+Changelog: debian/changelog
+Copyright: COPYING
+Readme: README
+Recommends:
+ ax-debian,
+Conflicts:
+ ax-debian (< 2),
+Architecture: all
+Files: alex-lenny.sources.list /etc/apt/sources.list.d/
+ debian.barton.de.gpg /etc/apt/trusted.gpg.d/
+Extra-Files: AUTHORS
+Description: Helper files to configure Alex' Debian package repository
+ This package configures the system to include Alex' own Debian package
+ repository and the required GnuPG key.
diff --git a/debian.barton.de.gpg b/debian.barton.de.gpg
new file mode 100644 (file)
index 0000000..741a6a6
Binary files /dev/null and b/debian.barton.de.gpg differ
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..abe8954
--- /dev/null
@@ -0,0 +1,5 @@
+ax-debian-repo (1) unstable; urgency=low
+
+  * Initial release.
+
+ -- Alexander Barton <alex@barton.de>  Thu, 30 Oct 2014 13:19:04 +0100