Update config.guess and config.sub to recent versions