Partially revert bc098794: don't require autoconf 2.67