configure.in: require autoconf 2.67 and automake 1.11
authorAlexander Barton <alex@barton.de>
Tue, 11 Sep 2012 12:30:49 +0000 (14:30 +0200)
committerAlexander Barton <alex@barton.de>
Tue, 11 Sep 2012 12:30:49 +0000 (14:30 +0200)
And use newer features such as bug reporting address and project URL.

configure.in

index 7a15b2ba5a4268c58253ad35a3c49d55448550ae..0f0cac02b8492853dd034f961b3616c526779c61 100644 (file)
@@ -13,12 +13,15 @@ define(VERSION_ID,esyscmd(git describe|sed -e 's/rel-//g'|sed -e 's/-/~/'|tr -d
 
 # -- Initialisation --
 
-AC_PREREQ(2.50)
-AC_INIT(ngircd, VERSION_ID)
-AC_CONFIG_SRCDIR(src/ngircd/ngircd.c)
+AC_PREREQ([2.67])
+AC_INIT([ngIRCd], VERSION_ID,
+       [ngircd-ml@ngircd.barton.de], [ngircd], [http://ngircd.barton.de/])
+
+AC_CONFIG_SRCDIR([src/ngircd/ngircd.c])
+AC_CONFIG_HEADER([src/config.h])
 AC_CANONICAL_TARGET
-AM_INIT_AUTOMAKE(1.6)
-AC_CONFIG_HEADER(src/config.h)
+
+AM_INIT_AUTOMAKE([1.11])
 
 m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])