Xcode: update project file to Xcode 3.2 or newer
authorAlexander Barton <alex@barton.de>
Sun, 7 Aug 2011 12:42:49 +0000 (14:42 +0200)
committerAlexander Barton <alex@barton.de>
Sun, 7 Aug 2011 12:42:49 +0000 (14:42 +0200)
Xcode requires Mac OS X 10.6 or newer; Xcode 4 supports this project
format as well, so effectively you can use Mac OS X 10.6.x or 10.7.x
for building ngIRCd with the Apple Xcode IDE.

contrib/MacOSX/ngIRCd.xcodeproj/project.pbxproj

index 8da2a81fa7c5ff9c3d199b9a0b1d9a3389a26768..42ddbf264b67649c7c17d1f0d9ae6aa6ea9129fd 100644 (file)
@@ -3,7 +3,7 @@
        archiveVersion = 1;
        classes = {
        };
-       objectVersion = 44;
+       objectVersion = 46;
        objects = {
 
 /* Begin PBXBuildFile section */
 /* Begin PBXProject section */
                08FB7793FE84155DC02AAC07 /* Project object */ = {
                        isa = PBXProject;
+                       attributes = {
+                               LastUpgradeCheck = 0410;
+                       };
                        buildConfigurationList = 1DEB928908733DD80010E9CD /* Build configuration list for PBXProject "ngIRCd" */;
-                       compatibilityVersion = "Xcode 3.0";
+                       compatibilityVersion = "Xcode 3.2";
                        developmentRegion = English;
                        hasScannedForEncodings = 1;
                        knownRegions = (
                1DEB928B08733DD80010E9CD /* Default */ = {
                        isa = XCBuildConfiguration;
                        buildSettings = {
-                               ARCHS = "$(ARCHS_STANDARD_32_64_BIT_PRE_XCODE_3_1)";
-                               ARCHS_STANDARD_32_64_BIT_PRE_XCODE_3_1 = "x86_64 i386 ppc";
-                               GCC_VERSION = 4.0;
+                               ARCHS = "$(ARCHS_STANDARD_32_64_BIT)";
+                               GCC_VERSION = 4.2;
                                GCC_WARN_ABOUT_RETURN_TYPE = YES;
                                GCC_WARN_UNUSED_VARIABLE = YES;
-                               PREBINDING = NO;
-                               SDKROOT = "$(DEVELOPER_SDK_DIR)/MacOSX10.5.sdk";
+                               SDKROOT = macosx10.6;
                        };
                        name = Default;
                };
                                ARCHS = "$(NATIVE_ARCH_ACTUAL)";
                                GCC_DEBUGGING_SYMBOLS = full;
                                GCC_OPTIMIZATION_LEVEL = 0;
-                               GCC_VERSION = 4.0;
+                               GCC_VERSION = 4.2;
                                GCC_WARN_ABOUT_RETURN_TYPE = YES;
                                GCC_WARN_UNUSED_VARIABLE = YES;
                                ONLY_ACTIVE_ARCH = YES;
-                               PREBINDING = NO;
                                SDKROOT = "";
                        };
                        name = Debug;