Loose GNU autoconf / automake requirements a bit
authorAlexander Barton <alex@barton.de>
Mon, 24 Sep 2012 08:22:21 +0000 (10:22 +0200)
committerAlexander Barton <alex@barton.de>
Mon, 24 Sep 2012 08:22:21 +0000 (10:22 +0200)
commitbaed0618ed9e1a9140624205035d991d7852ee6b
treea6b7aa2fa85df53f2895826e35cb4285f0d653ab
parente3e181f4b3eae0e552632bce19bdff990196938f
Loose GNU autoconf / automake requirements a bit

Now ngIRCd requires at least GNU autoconf 2.61 and automake 1.10, the
requirements of commit 67e882d4 have been too restrictive:

             19.2      67e882d4  now
  ---------- --------- --------- ---------
  autoconf   >=2.50    >=2.67    >=2.61
  automake   >=1.6     >=1.11    >=1.10

The tools required now are supported by Debian GNU/Linux 4.0 "Etch",
RedHat Enterprise Linux 5, and Mac OS X 10.6.x for example.

I read the changelogs of autoconf and automake, and I think ther's nothing
that prevents it from working with these older versions; and we don't want
to force users to upgrade without real benefits.

Please note: the recommended versions are still autoconf 1.11.x and the
most recent autoconf release that works with automake 1.11.x!
configure.in