]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- "ansi2knr" zur "DeANSIfikation" als automake-Option gesetzt.
[ngircd-alex.git] / src / ngircd / Makefile.am
index 0c5dab0fccc044101c08a39822eef5bc7c5b119d..f802078eb4b3e2c6ccd1ec22f928318f3d32967f 100644 (file)
@@ -9,9 +9,11 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.18 2002/03/25 19:38:16 alex Exp $
+# $Id: Makefile.am,v 1.22 2002/05/22 09:09:43 alex Exp $
 #
 
+AUTOMAKE_OPTIONS = ../portab/ansi2knr
+
 AM_CFLAGS = -I$(srcdir)/../portab
 
 LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
@@ -22,6 +24,10 @@ ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
        irc-channel.c irc-login.c irc-mode.c irc-oper.c irc-server.c \
        irc-write.c log.c parse.c tool.c
 
+ngircd_LDFLAGS = -L../portab
+
+ngircd_LDADD = -lngportab
+
 noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
        irc-channel.h irc-login.h irc-mode.h irc-oper.h irc-server.h \
        irc-write.h log.h parse.h tool.h \
@@ -54,9 +60,6 @@ lint:
         fi; \
        done;
 
-install-data-hook:
-       $(mkinstalldirs) $(DESTDIR)$(localstatedir)
-
 TESTS = check-version check-help
 
 # -eof-