]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- Added new source module "rendezvous".
[ngircd-alex.git] / src / ngircd / Makefile.am
index 34bb71ff81e753528c1ea460ab568f09f13b74f8..b36b99ad24e077efe42b8ed3030ebc221ff189b3 100644 (file)
@@ -1,20 +1,19 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001,2002 by Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2003 by Alexander Barton (alex@barton.de)
 #
-# Dieses Programm ist freie Software. Sie koennen es unter den Bedingungen
-# der GNU General Public License (GPL), wie von der Free Software Foundation
-# herausgegeben, weitergeben und/oder modifizieren, entweder unter Version 2
-# der Lizenz oder (wenn Sie es wuenschen) jeder spaeteren Version.
-# Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
-# der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+# Please read the file COPYING, README and AUTHORS for more information.
 #
-# $Id: Makefile.am,v 1.34 2003/01/02 16:42:33 alex Exp $
+# $Id: Makefile.am,v 1.37 2003/02/23 12:02:26 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
 
-INCLUDES = -I$(srcdir)/../portab
+INCLUDES = -I$(srcdir)/../portab -I$(srcdir)/../tool
 
 LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
 
@@ -22,17 +21,18 @@ sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c conn-zip.c conn-func.c \
        hash.c irc.c irc-channel.c irc-info.c irc-login.c irc-mode.c irc-op.c \
-       irc-oper.c irc-server.c irc-write.c lists.c log.c match.c parse.c resolve.c \
-       tool.c
+       irc-oper.c irc-server.c irc-write.c lists.c log.c match.c parse.c \
+       rendezvous.c resolve.c
 
-ngircd_LDFLAGS = -L../portab
+ngircd_LDFLAGS = -L../portab -L../tool
 
-ngircd_LDADD = -lngportab
+ngircd_LDADD = -lngportab -lngtool
 
 noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h conn-zip.h conn-func.h \
        hash.h irc.h irc-channel.h irc-info.h irc-login.h irc-mode.h irc-op.h \
-       irc-oper.h irc-server.h irc-write.h lists.h log.h match.h parse.h resolve.h \
-       tool.h messages.h defines.h
+       irc-oper.h irc-server.h irc-write.h lists.h log.h match.h parse.h \
+       rendezvous.h resolve.h \
+       messages.h defines.h
 
 clean-local:
        rm -f check-version check-help lint.out cvs-version.*
@@ -66,7 +66,7 @@ ngircd.c: cvs-date cvs-version.h
 cvs-date:
        grep VERSION ../config.h | grep "CVS" \
         && echo "#define CVSDATE \"$$( grep "\$$Id" $(srcdir)/*.c \
-           | $(AWK) "{ print \$$9 }" | sort | tail -1 \
+           | $(AWK) "{ print \$$9 }" | sort | tail -1 \
            | sed -e "s/\//-/g" )\"" > cvs-version.new \
         || echo "" > cvs-version.new
        diff cvs-version.h cvs-version.new || cp cvs-version.new cvs-version.h