]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- ngircd wird nun gegen die libngportab gelinkt, die evtl. benoetigte
[ngircd-alex.git] / src / ngircd / Makefile.am
index 2e2b8dc61569f04f2a764a4b668386eb2cd0dcfd..7b42f5ceb2dfd35d3bec13cfb6ae4c6e83fc23ca 100644 (file)
@@ -9,24 +9,28 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.17 2002/03/14 15:31:22 alex Exp $
+# $Id: Makefile.am,v 1.20 2002/05/19 01:15:55 alex Exp $
 #
 
 AM_CFLAGS = -I$(srcdir)/../portab
 
 #
 
 AM_CFLAGS = -I$(srcdir)/../portab
 
+LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
+
 sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
        irc-channel.c irc-login.c irc-mode.c irc-oper.c irc-server.c \
        irc-write.c log.c parse.c tool.c
 
 sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
        irc-channel.c irc-login.c irc-mode.c irc-oper.c irc-server.c \
        irc-write.c log.c parse.c tool.c
 
+ngircd_LDFLAGS = -L../portab -lngportab
+
 noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
        irc-channel.h irc-login.h irc-mode.h irc-oper.h irc-server.h \
        irc-write.h log.h parse.h tool.h \
        messages.h defines.h
 
 clean-local:
 noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
        irc-channel.h irc-login.h irc-mode.h irc-oper.h irc-server.h \
        irc-write.h log.h parse.h tool.h \
        messages.h defines.h
 
 clean-local:
-       rm -f check-version check-help
+       rm -f check-version check-help lint.out
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
@@ -41,8 +45,16 @@ check-help: Makefile
        echo "./ngircd --help | grep help > /dev/null 2>&1" >> check-help
        chmod 755 check-help
 
        echo "./ngircd --help | grep help > /dev/null 2>&1" >> check-help
        chmod 755 check-help
 
-install-data-hook:
-       $(mkinstalldirs) $(DESTDIR)$(localstatedir)
+lint:
+       rm -f lint.out
+       for f in *.c; do \
+        echo "checking $$f ..."; \
+        splint $$f $(LINTARGS) -I./.. $(AM_CFLAGS) > lint.out 2>&1; \
+        grep "no warnings" lint.out > /dev/null 2>&1; \
+        if [ $$? -ne 0 ]; then \
+         echo; cat lint.out; echo; \
+        fi; \
+       done;
 
 TESTS = check-version check-help
 
 
 TESTS = check-version check-help