]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
Introduce option to configure the maximum nick name lenth in ngircd.conf
[ngircd-alex.git] / src / ngircd / Makefile.am
index f5a7d83463f0fa46e26b19ca5f087e05731d9a65..46513a8a54da042e4b74fbc21ef165ed23c20b4c 100644 (file)
@@ -8,7 +8,7 @@
 # (at your option) any later version.
 # Please read the file COPYING, README and AUTHORS for more information.
 #
-# $Id: Makefile.am,v 1.44 2005/04/09 12:30:55 alex Exp $
+# $Id: Makefile.am,v 1.50 2007/11/21 12:16:36 alex Exp $
 #
 
 AUTOMAKE_OPTIONS = ../portab/ansi2knr
@@ -16,24 +16,24 @@ AUTOMAKE_OPTIONS = ../portab/ansi2knr
 INCLUDES = -I$(srcdir)/../portab -I$(srcdir)/../tool
 
 LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN \
- -varuse -retvalother -emptyret
+ -varuse -retvalother -emptyret -unrecog
 
 sbin_PROGRAMS = ngircd
 
-ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c conn-zip.c conn-func.c \
-       hash.c irc.c irc-channel.c irc-info.c irc-login.c irc-mode.c irc-op.c \
-       irc-oper.c irc-server.c irc-write.c lists.c log.c match.c parse.c \
-       rendezvous.c resolve.c
+ngircd_SOURCES = ngircd.c array.c channel.c client.c conf.c conn.c conn-func.c \
+       conn-zip.c hash.c io.c irc.c irc-channel.c irc-info.c irc-login.c \
+       irc-mode.c irc-op.c irc-oper.c irc-server.c irc-write.c lists.c log.c \
+       match.c numeric.c parse.c rendezvous.c resolve.c
 
 ngircd_LDFLAGS = -L../portab -L../tool
 
 ngircd_LDADD = -lngportab -lngtool
 
-noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h conn-zip.h conn-func.h \
-       hash.h irc.h irc-channel.h irc-info.h irc-login.h irc-mode.h irc-op.h \
-       irc-oper.h irc-server.h irc-write.h lists.h log.h match.h parse.h \
-       rendezvous.h resolve.h \
-       messages.h defines.h
+noinst_HEADERS = ngircd.h array.h channel.h client.h conf.h conn.h conn-func.h \
+       conn-zip.h hash.h io.h irc.h irc-channel.h irc-info.h irc-login.h \
+       irc-mode.h irc-op.h irc-oper.h irc-server.h irc-write.h lists.h log.h \
+       match.h numeric.h parse.h rendezvous.h resolve.h \
+       defines.h messages.h
 
 clean-local:
        rm -f check-version check-help lint.out cvs-version.*
@@ -43,12 +43,12 @@ maintainer-clean-local:
 
 check-version: Makefile
        echo "#!/bin/sh" > check-version
-       echo "./ngircd --version | grep ngircd > /dev/null 2>&1" >> check-version
+       echo "./ngircd --version | grep ngircd >/dev/null 2>&1" >>check-version
        chmod 755 check-version
 
 check-help: Makefile
        echo "#!/bin/sh" > check-help
-       echo "./ngircd --help | grep help > /dev/null 2>&1" >> check-help
+       echo "./ngircd --help | grep help >/dev/null 2>&1" >>check-help
        chmod 755 check-help
 
 lint:
@@ -63,8 +63,8 @@ lint:
         if [ $$? -ne 0 ]; then \
          waswarning=1; \
          echo; grep -v "^Command Line: " lint.out; echo; \
-         w=$$( grep "code warning" lint.out | awk "{ print \$$4 }" ); \
-         warnings=`expr $$warnings + $$w`; \
+         w=$$( grep "code warning" lint.out | $(AWK) "{ print \$$4 }" ); \
+         [ "$$w" -gt 0 ] && warnings=`expr $$warnings + $$w`; \
          files=`expr $$files + 1`; \
         else \
          waswarning=0; \