]> arthur.barton.de Git - ngircd-alex.git/blobdiff - src/ngircd/Makefile.am
- das "localstatedir" wird nicht mehr erzeugt, da nicht mehr benoetigt.
[ngircd-alex.git] / src / ngircd / Makefile.am
index 2e2b8dc61569f04f2a764a4b668386eb2cd0dcfd..1bc53ac1718444968dd20298a49919f1236839a3 100644 (file)
@@ -9,11 +9,13 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.17 2002/03/14 15:31:22 alex Exp $
+# $Id: Makefile.am,v 1.19 2002/03/29 22:52:12 alex Exp $
 #
 
 AM_CFLAGS = -I$(srcdir)/../portab
 
+LINTARGS = -weak -warnunixlib +unixlib -booltype BOOLEAN
+
 sbin_PROGRAMS = ngircd
 
 ngircd_SOURCES = ngircd.c channel.c client.c conf.c conn.c hash.c irc.c \
@@ -26,7 +28,7 @@ noinst_HEADERS = ngircd.h channel.h client.h conf.h conn.h hash.h irc.h \
        messages.h defines.h
 
 clean-local:
-       rm -f check-version check-help
+       rm -f check-version check-help lint.out
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
@@ -41,8 +43,16 @@ check-help: Makefile
        echo "./ngircd --help | grep help > /dev/null 2>&1" >> check-help
        chmod 755 check-help
 
-install-data-hook:
-       $(mkinstalldirs) $(DESTDIR)$(localstatedir)
+lint:
+       rm -f lint.out
+       for f in *.c; do \
+        echo "checking $$f ..."; \
+        splint $$f $(LINTARGS) -I./.. $(AM_CFLAGS) > lint.out 2>&1; \
+        grep "no warnings" lint.out > /dev/null 2>&1; \
+        if [ $$? -ne 0 ]; then \
+         echo; cat lint.out; echo; \
+        fi; \
+       done;
 
 TESTS = check-version check-help