]> arthur.barton.de Git - ngircd-alex.git/blobdiff - man/Makefile.am
Don't abort startup when setgid/setuid() fails with EINVAL
[ngircd-alex.git] / man / Makefile.am
index 4f3dd45afcef2d9c0e6ad367269ad731495d6599..077d0eabad1b6b8edf2d7846476d803b8552775b 100644 (file)
@@ -1,21 +1,30 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001,2002 by Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2012 Alexander Barton (alex@barton.de) and Contributors
 #
-# Dieses Programm ist freie Software. Sie koennen es unter den Bedingungen
-# der GNU General Public License (GPL), wie von der Free Software Foundation
-# herausgegeben, weitergeben und/oder modifizieren, entweder unter Version 2
-# der Lizenz oder (wenn Sie es wuenschen) jeder spaeteren Version.
-# Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
-# der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
-#
-# $Id: Makefile.am,v 1.3 2002/04/02 18:13:47 alex Exp $
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+# Please read the file COPYING, README and AUTHORS for more information.
 #
 
+TEMPLATE_MANS = ngircd.conf.5.tmpl ngircd.8.tmpl
+
+SUFFIXES = .tmpl .
+
+.tmpl:
+       $(AM_V_GEN)sed \
+           -e "s@:SBINDIR:@${sbindir}@" \
+           -e "s@:BINDIR:@${bindir}@" \
+           -e "s@:ETCDIR:@${sysconfdir}@" \
+           <$< >$@
+
 man_MANS = ngircd.conf.5 ngircd.8
 
-clean-local:
-       rm -f *.[0-9]
+CLEANFILES = $(man_MANS)
+
+EXTRA_DIST = $(TEMPLATE_MANS)
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in