]> arthur.barton.de Git - ngircd-alex.git/blobdiff - doc/Makefile.am
Add doc/Contributing.txt to distribution archive
[ngircd-alex.git] / doc / Makefile.am
index 2960e404f54c46db1f085ba7308e28af952f891a..cd51d7fe0de1d1c7d73231868f32068faf96b7ba 100644 (file)
@@ -1,29 +1,93 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001,2002 by Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2012 Alexander Barton (alex@barton.de) and Contributors
 #
-# Dieses Programm ist freie Software. Sie koennen es unter den Bedingungen
-# der GNU General Public License (GPL), wie von der Free Software Foundation
-# herausgegeben, weitergeben und/oder modifizieren, entweder unter Version 2
-# der Lizenz oder (wenn Sie es wuenschen) jeder spaeteren Version.
-# Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
-# der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
-#
-# $Id: Makefile.am,v 1.10 2002/09/16 10:35:06 alex Exp $
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+# Please read the file COPYING, README and AUTHORS for more information.
 #
 
-SUBDIRS = en
+.tmpl:
+       $(AM_V_GEN)sed \
+           -e s@:ETCDIR:@${sysconfdir}@ \
+           <$< >$@
+
+SUFFIXES = .tmpl
+
+static_docs = \
+       Bopm.txt \
+       Capabilities.txt \
+       Contributing.txt \
+       FAQ.txt \
+       GIT.txt \
+       HowToRelease.txt \
+       Modes.txt \
+       PAM.txt \
+       Platforms.txt \
+       Protocol.txt \
+       README-AUX.txt \
+       README-BeOS.txt \
+       README-Interix.txt \
+       RFC.txt \
+       Services.txt \
+       SSL.txt
+
+doc_templates = sample-ngircd.conf.tmpl
+
+generated_docs = sample-ngircd.conf
+
+toplevel_docs = ../AUTHORS ../COPYING ../ChangeLog ../INSTALL ../NEWS ../README
+
+SUBDIRS = src
 
-EXTRA_DIST = CVS.txt FAQ.txt Protocol.txt README-AUX.txt \
-       README-BeOS.txt RFC.txt sample-ngircd.conf
+EXTRA_DIST = $(static_docs) $(doc_templates)
+
+CLEANFILES = $(generated_docs)
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
-install-data-hook:
+all: $(generated_docs)
+
+install-data-hook: $(static_docs) $(toplevel_docs) $(generated_docs)
        $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
-       if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
-         $(INSTALL) -m 600 -c $(srcdir)/sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; \
-         fi
+       @if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
+         make install-config; \
+        fi
+       $(mkinstalldirs) $(DESTDIR)$(docdir)
+       for f in $(static_docs) $(toplevel_docs); do \
+         $(INSTALL) -m 644 -c $(srcdir)/$$f $(DESTDIR)$(docdir)/; \
+        done
+       for f in $(generated_docs); do \
+         $(INSTALL) -m 644 -c $$f $(DESTDIR)$(docdir)/; \
+        done
+
+install-config:
+       $(INSTALL) -m 600 -c sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf
+       @echo; \
+        echo " ** NOTE: Installed sample configuration file:"; \
+        echo " ** \"$(DESTDIR)$(sysconfdir)/ngircd.conf\""; \
+        echo
+
+uninstall-hook:
+       rm -rf $(DESTDIR)$(docdir)
+       @if cmp --silent sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; then \
+         make uninstall-config; \
+        else \
+         echo; \
+         echo " ** NOTE: Not uninstalling changed configuration file:"; \
+         echo " ** \"$(DESTDIR)$(sysconfdir)/ngircd.conf\""; \
+         echo; \
+        fi
+
+uninstall-config:
+       rm -f $(DESTDIR)$(sysconfdir)/ngircd.conf
+
+srcdoc:
+       make -C src srcdoc
+
+.PHONY: install-config uninstall-config srcdoc
 
 # -eof-