]> arthur.barton.de Git - ngircd-alex.git/blobdiff - doc/Makefile.am
Remote GIT.txt from Makefile[.am], too!
[ngircd-alex.git] / doc / Makefile.am
index eb6fa93778927f9760c3a7bcad07f2489bbea2fb..5913c94ee1fdd05fbd34808c80d3e11646e79cb3 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2012 Alexander Barton (alex@barton.de) and Contributors
+# Copyright (c)2001-2015 Alexander Barton (alex@barton.de) and Contributors
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -12,6 +12,7 @@
 .tmpl:
        $(AM_V_GEN)sed \
            -e "s@:ETCDIR:@${sysconfdir}@" \
+           -e "s@:DOCDIR:@${docdir}@" \
            <$< >$@
 
 SUFFIXES = .tmpl
@@ -22,7 +23,6 @@ static_docs = \
        Commands.txt \
        Contributing.txt \
        FAQ.txt \
-       GIT.txt \
        HowToRelease.txt \
        Modes.txt \
        PAM.txt \
@@ -53,11 +53,11 @@ maintainer-clean-local:
 all: $(generated_docs)
 
 install-data-hook: $(static_docs) $(toplevel_docs) $(generated_docs)
-       $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+       $(MKDIR_P) -m 755 $(DESTDIR)$(sysconfdir)
        @if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
          make install-config; \
         fi
-       $(mkinstalldirs) $(DESTDIR)$(docdir)
+       $(MKDIR_P) -m 755 $(DESTDIR)$(docdir)
        for f in $(static_docs) $(toplevel_docs); do \
          $(INSTALL) -m 644 -c $(srcdir)/$$f $(DESTDIR)$(docdir)/; \
         done