]> arthur.barton.de Git - ngircd-alex.git/blobdiff - doc/Makefile.am
Use $(MKDIR_P) instead of $(mkinstalldirs) in Makefile's
[ngircd-alex.git] / doc / Makefile.am
index cd51d7fe0de1d1c7d73231868f32068faf96b7ba..27942dd3d05c32c0326253d6cadece421506110e 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2012 Alexander Barton (alex@barton.de) and Contributors
+# Copyright (c)2001-2013 Alexander Barton (alex@barton.de) and Contributors
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -11,7 +11,8 @@
 
 .tmpl:
        $(AM_V_GEN)sed \
-           -e s@:ETCDIR:@${sysconfdir}@ \
+           -e "s@:ETCDIR:@${sysconfdir}@" \
+           -e "s@:DOCDIR:@${docdir}@" \
            <$< >$@
 
 SUFFIXES = .tmpl
@@ -19,6 +20,7 @@ SUFFIXES = .tmpl
 static_docs = \
        Bopm.txt \
        Capabilities.txt \
+       Commands.txt \
        Contributing.txt \
        FAQ.txt \
        GIT.txt \
@@ -52,11 +54,11 @@ maintainer-clean-local:
 all: $(generated_docs)
 
 install-data-hook: $(static_docs) $(toplevel_docs) $(generated_docs)
-       $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+       $(MKDIR_P) -m 755 $(DESTDIR)$(sysconfdir)
        @if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
          make install-config; \
         fi
-       $(mkinstalldirs) $(DESTDIR)$(docdir)
+       $(MKDIR_P) -m 755 $(DESTDIR)$(docdir)
        for f in $(static_docs) $(toplevel_docs); do \
          $(INSTALL) -m 644 -c $(srcdir)/$$f $(DESTDIR)$(docdir)/; \
         done