]> arthur.barton.de Git - ngircd-alex.git/blobdiff - doc/Makefile.am
Install documentation files in $(datadir)/doc/ngircd.
[ngircd-alex.git] / doc / Makefile.am
index 2960e404f54c46db1f085ba7308e28af952f891a..1d1e3b4b60c6c059962f977d4762213734c4fb49 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001,2002 by Alexander Barton (alex@barton.de)
+# Copyright (c)2001-2003 by Alexander Barton (alex@barton.de)
 #
 # Dieses Programm ist freie Software. Sie koennen es unter den Bedingungen
 # der GNU General Public License (GPL), wie von der Free Software Foundation
@@ -9,21 +9,28 @@
 # Naehere Informationen entnehmen Sie bitter der Datei COPYING. Eine Liste
 # der an ngIRCd beteiligten Autoren finden Sie in der Datei AUTHORS.
 #
-# $Id: Makefile.am,v 1.10 2002/09/16 10:35:06 alex Exp $
+# $Id: Makefile.am,v 1.13 2003/03/30 13:31:17 alex Exp $
 #
 
-SUBDIRS = en
-
 EXTRA_DIST = CVS.txt FAQ.txt Protocol.txt README-AUX.txt \
        README-BeOS.txt RFC.txt sample-ngircd.conf
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
+docdir = $(datadir)/doc/ngircd
+
+documents = $(EXTRA_DIST) ../AUTHORS ../COPYING ../ChangeLog ../INSTALL \
+       ../NEWS ../README
+
 install-data-hook:
        $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
        if [ ! -f $(DESTDIR)$(sysconfdir)/ngircd.conf ]; then \
          $(INSTALL) -m 600 -c $(srcdir)/sample-ngircd.conf $(DESTDIR)$(sysconfdir)/ngircd.conf; \
-         fi
+        fi
+       $(mkinstalldirs) $(DESTDIR)$(docdir)
+       for f in $(documents); do \
+         $(INSTALL) -m 644 -c $(srcdir)/$$f $(DESTDIR)$(docdir)/; \
+        done
 
 # -eof-