]> arthur.barton.de Git - ngircd-alex.git/blobdiff - contrib/ngircd.spec
Xcode: remove imp.h and exp.h from project file
[ngircd-alex.git] / contrib / ngircd.spec
index 2f386e086e1c3003f10651c819581d62521e41b4..ab4e0c98ccd7d70ce32d956d835d9595dc61e104 100644 (file)
@@ -1,37 +1,42 @@
 %define name    ngircd
-%define version CurrentCVS
+%define version 21
 %define release 1
 %define prefix  %{_prefix}
 
-Summary:      Next Generation Internet Relay Chat Daemon
+Summary:      A lightweight daemon for the Internet Relay Chat (IRC)
 Name:         %{name}
 Version:      %{version}
 Release:      %{release}
-Copyright:    GPL
-Group:        Networking/Daemons
-URL:          http://arthur.ath.cx/~alex/ngircd/
+License:      GPLv2+
+Group:        System Environment/Daemons
+URL:          http://ngircd.barton.de/
 Source:       %{name}-%{version}.tar.gz
-Packager:     Sean Reifschneider <jafo-rpms@tummy.com>
-BuildRoot:    /var/tmp/%{name}-root
+BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires:  zlib-devel, openssl-devel
 
 %description
-ngIRCd is a free open source daemon for Internet Relay Chat (IRC),
-developed under the GNU General Public License (GPL). It's written from
-scratch and is not based upon the original IRCd like many others.
-
-Why should you use ngIRCd? Because ...
-
-   * ... there are no problems with servers on changing or non-static IP
-         addresses.
-   * ... there is a small and lean configuration file.
-   * ... there is a free, modern and open source C source code.
-   * ... it is still under active development. 
+This package provides ngIRCd, a portable and lightweight Internet Relay
+Chat server for small or private networks, developed under the GNU
+General Public License (GPL). It is simple to configure, can cope with
+dynamic IP addresses, and supports IPv6 as well as SSL. It is written
+from scratch and not based on the original IRCd.
+
+Advantages:
+ - well arranged (lean) configuration file
+ - simple to build/install, configure and maintain
+ - supports IPv6 and SSL
+ - no problems with servers that have dynamic IP addresses
+ - freely available, modern, portable and tidy C-source
+ - ngIRCd is being actively developed since 11 years.
 
 %prep
-%setup
+%setup -q
 %build
-%configure
-make
+%configure \
+  --with-zlib \
+  --with-openssl
+
+make %{?_smp_mflags}
 
 %install
 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
@@ -41,6 +46,7 @@ make
    ( cd usr/sbin; mv *-ngircd ngircd )
    ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
    ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
+   rm -fr usr/share/doc/ngircd
 )
 
 %clean
@@ -48,7 +54,8 @@ make
 
 %files
 %defattr(755,root,root)
-%doc AUTHORS  COPYING  ChangeLog  INSTALL NEWS  README
+%doc AUTHORS  COPYING  ChangeLog  INSTALL NEWS  README doc/*
 %config(noreplace) /etc
 %{_prefix}/sbin
-%{_prefix}/share/man/
+%{_mandir}/man5/ngircd.conf*
+%{_mandir}/man8/ngircd.8*