]> arthur.barton.de Git - ngircd-alex.git/blobdiff - contrib/MacOSX/Makefile.am
Fix typo: Please not -> Please note
[ngircd-alex.git] / contrib / MacOSX / Makefile.am
index 306e41f152a4ab6c50a470166c6128d4e05720d2..abd799c58c00a36b6d1f1488287fdb23d1a6ec5a 100644 (file)
@@ -8,12 +8,10 @@
 # (at your option) any later version.
 # Please read the file COPYING, README and AUTHORS for more information.
 #
-# $Id: Makefile.am,v 1.3 2008/02/17 15:31:15 alex Exp $
-#
 
-SUBDIRS = ngIRCd.xcodeproj
+SUBDIRS = ngIRCd.xcodeproj ngIRCd.pmdoc
 
-EXTRA_DIST = de.barton.ngircd.plist.tmpl config.h cvs-version.h
+EXTRA_DIST = de.barton.ngircd.plist.tmpl config.h preinstall.sh postinstall.sh
 
 SUFFIXES = .tmpl .
 
@@ -36,7 +34,9 @@ install-sys-darwin:
        fi
 
 install-sys-darwin-root: de.barton.ngircd.plist
-       install -c -m 644 -b -o root -g wheel de.barton.ngircd.plist /Library/LaunchDaemons/de.barton.ngircd.plist
+       install -d -m 755 -o root -g wheel $(DESTDIR)/Library/LaunchDaemons
+       install -c -m 644 -b -o root -g wheel de.barton.ngircd.plist \
+        $(DESTDIR)/Library/LaunchDaemons/de.barton.ngircd.plist
        @echo
        @echo " ** \"/Library/LaunchDaemons/de.barton.ngircd.plist\" has been installed,"
        @echo " ** but is disabled. Use launchctl(8) to enable/run ngIRCd on Darwin/Mac OS X."
@@ -44,6 +44,7 @@ install-sys-darwin-root: de.barton.ngircd.plist
 
 clean-local:
        rm -rf build
+       rm -f de.barton.ngircd.plist
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in