]> arthur.barton.de Git - ngircd-alex.git/blob - contrib/ngircd.spec
efd7f2c573c98a06fa3dcc71ab3f4c9478f1ded1
[ngircd-alex.git] / contrib / ngircd.spec
1 %define name    ngircd
2 %define version 23~rc1
3 %define release 1
4 %define prefix  %{_prefix}
5
6 Summary:      A lightweight daemon for the Internet Relay Chat (IRC)
7 Name:         %{name}
8 Version:      %{version}
9 Release:      %{release}
10 License:      GPLv2+
11 Group:        System Environment/Daemons
12 URL:          http://ngircd.barton.de/
13 Source:       %{name}-%{version}.tar.gz
14 BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15 BuildRequires:  zlib-devel, openssl-devel
16
17 %description
18 This package provides ngIRCd, a portable and lightweight Internet Relay
19 Chat server for small or private networks, developed under the GNU
20 General Public License (GPL). It is simple to configure, can cope with
21 dynamic IP addresses, and supports IPv6 as well as SSL. It is written
22 from scratch and not based on the original IRCd.
23
24 Advantages:
25  - well arranged (lean) configuration file
26  - simple to build/install, configure and maintain
27  - supports IPv6 and SSL
28  - no problems with servers that have dynamic IP addresses
29  - freely available, modern, portable and tidy C-source
30  - ngIRCd is being actively developed since 11 years.
31
32 %prep
33 %setup -q
34 %build
35 %configure \
36   --with-zlib \
37   --with-openssl
38
39 make %{?_smp_mflags}
40
41 %install
42 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
43 %makeinstall
44 (
45    cd "$RPM_BUILD_ROOT"
46    ( cd usr/sbin; mv *-ngircd ngircd )
47    ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
48    ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
49    rm -fr usr/share/doc/ngircd
50 )
51
52 %clean
53 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
54
55 %files
56 %defattr(755,root,root)
57 %doc AUTHORS  COPYING  ChangeLog  INSTALL NEWS  README doc/*
58 %config(noreplace) /etc
59 %{_prefix}/sbin
60 %{_mandir}/man5/ngircd.conf*
61 %{_mandir}/man8/ngircd.8*