]> arthur.barton.de Git - ngircd-alex.git/blob - contrib/ngircd.spec
d83ff70246657433e5103af7eddbc59700b39295
[ngircd-alex.git] / contrib / ngircd.spec
1 %define name    ngircd
2 %define version 16~rc1
3 %define release 1
4 %define prefix  %{_prefix}
5
6 Summary:      A lightweight daemon for the Internet Relay Chat (IRC)
7 Name:         %{name}
8 Version:      %{version}
9 Release:      %{release}
10 License:      GPLv2+
11 Group:        System Environment/Daemons
12 URL:          http://ngircd.barton.de/
13 Source:       %{name}-%{version}.tar.gz
14 BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15 BuildRequires:  zlib-devel, openssl-devel
16
17 %description
18 ngIRCd is a free open source daemon for the Internet Relay Chat (IRC),
19 developed under the GNU General Public License (GPL). It's written from
20 scratch and is not based upon the original IRCd like many others.
21
22 Advantages:
23  - no problems with servers using changing/non-static IP addresses.
24  - small and lean configuration file.
25  - free, modern and open source C code.
26  - still under active development.
27
28 ngIRCd is compatible to the "original" ircd 2.10.3p3, so you can run
29 mixed networks.
30
31 %prep
32 %setup -q
33 %build
34 %configure \
35   --with-zlib \
36   --with-openssl
37
38 make %{?_smp_mflags}
39
40 %install
41 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
42 %makeinstall
43 (
44    cd "$RPM_BUILD_ROOT"
45    ( cd usr/sbin; mv *-ngircd ngircd )
46    ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
47    ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
48    rm -fr usr/share/doc/ngircd
49 )
50
51 %clean
52 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
53
54 %files
55 %defattr(755,root,root)
56 %doc AUTHORS  COPYING  ChangeLog  INSTALL NEWS  README doc/*
57 %config(noreplace) /etc
58 %{_prefix}/sbin
59 %{_mandir}/man5/ngircd.conf*
60 %{_mandir}/man8/ngircd.8*